How to close side bar without stopping audio?



  • Hi community

    I'm still using side bar menu with Vivaldi. I'm using it to manage my YouTube playlist while browsing or reading something. It seems that it is not possible to close the side bar without stopping the music. Is there a way to correct this; did somebody try it?

    Thanks



  • I can confirm it for youtube. Personally I'm using live radio in the panel and it doesn't stop when the panel is is being closed, although it stops when the panel container is being hidden – but this is probably intended. What I don't appreciate is that all webpanels are being reloaded if you add or remove one.



  • Hey!
    @Lampadron @luetage The panel page should continue to work normally even if not displayed, but most of the time these issues come from the fact that the website itself is coded to behave differently on the mobile version.
    For example, YouTube does not allow background playback on mobile.

    The solution: display the desktop version of the panel instead of the mobile one 😉 (right click on the panel icon, "Show desktop version").

    The mobile version is the default one because it is more adapted to the small space available in the panel area. However, lot of website behave well in this area even when set as "show desktop version", so it is often worth giving a try when you have such problems.



  • @guilimote You should have checked before posting. The youtube desktop version stops playing too. But yeah, this is probably youtube's fault.

    However, my "complaint" about all webpanels reloading when a webpanel is added/removed has nothing to do with it – this is done by Vivaldi's native code.



  • @luetage Ok, sorry, I haven't checked recently indeed, so you must be right. However, it used to work only when forced to "desktop version", hence my answer... ex: https://forum.vivaldi.net/topic/12356/youtube-in-side-panel-stops-playing-after-hiding-the-paneel

    Don't know about your "reload" issue. You may try to report it in the bug tracker.

    Edit: after a recheck on my side, it does work when switched to desktop, even if the panel is hidden... (1.14.1077.55 on Ubuntu 14.04)



  • @guilimote Doesn't work on latest snapshot macOS.

    Anyway, I reported this as a bug now, but I have the feeling the reloading is intended behaviour, because this "bug" is very hard to miss and is aboard since the introduction of webpanels. VB-39285



  • I don't think this would affect the panel, but under tab settings there is an option for tab muting. You might check and see what that is set to.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.