証明書失効サイトにアクセスするとページがクラッシュしてしまう



  • 1.15.1125.3以降、証明書失効サイトにアクセスするとページがクラッシュするようになりました。
    詳細は下記となります。

    利用OS
    ・windows8.1
    ・windows10

    1.15.1111.3 (公式ビルド) (64-bit)
    0_1522479590523_02992a07-2f36-44a7-9ac4-b819cc9d10fe.png

    1.15.1137.3 (公式ビルド) (64-bit)
    0_1522479663086_11c59118-2a19-4b23-9a19-e38956821bf5.png



  • 投稿フォーラムを間違えてており、申し訳ありませんでした。

    検証用URL:https://skins.minecraft.net
    1.15.1146.5 (公式ビルド) (64-bit)でも確認しましたが、まだ改善されてないようです。
    お手数ですがご確認お願いいたします。

    追記:プライベートモードでもクラッシュするのを確認しました。
    0_1523102729291_検証_失効エラーアクセス.png



  • ご確認頂きありがとうございます。
    インラインにて回答いたします。

    ページが白紙の状態で一切の操作を受け付けない状態ですか?

    そのタブページ内での操作が受け付けなくなる状態です。
    タブを閉じたりすることは可能です。

    1.新規ユーザーを作って表示されるか。

    新規ユーザーを作成しても状況は変わらず白紙状態です。

    2.chrome他のブラウザーで問題のサイトが正常に表示されるか。

    IEとFirefoxで試したところ正常に表示されています。

    3.セキュリティソフトは何を使っているのか。

    win8.1,win10共にMcafeeを使用してます。

    4.セキュリティソフトの設定で証明切れのサイトが遮断されていないか、一時的にオフにして表示できるかどうか。

    オフにして試しましたが、白紙状態でした。

    5.今でも1.15.1125.3以前のバージョンに問題が古いバージョンをスタンドインストールをし正常に表示するかどうか。

    1.15.1111.3 (公式ビルド) (64-bit)で試したところ正常に表示されています。
    ※セキュリティソフトのMcafeeはオンにした状態です。


    試しにサイト情報のFlash設定を確認(デフォルト) からこのサイトでは常に許可
    変更したところ1.15.1146.5でも正常に表示できるのを確認しました。
    しかし、タブを閉じ再度アクセスするとまた白紙の状態に戻ってしまいます。
    Flash関連の設定が1.15.1125.3以降変わったのでしょうか?


    0_1523112927531_検証_失効エラーアクセス2.png



  • zyxwjさんの元でも再現されたようでなによりです。
    詳細な指示を出して頂き助かりました。

    修復が終わるまでFlashオプション操作での対応をお願いします。

    マイナー不具合だと思いますので、上記暫定対応で気長に待ちます。



  • @todo184184 @zyxwj

    自分が解釈を間違えている可能性がありますがページにアクセスしただけで
    クラッシュするのでしょうか?

    一応、情報は多い方がいいと思ってこっちの方でも試してみたところ
    アクセスしただけではクラッシュする現象はなかったものの Flash の設定に
    関わらず、セキュリティで保護されたページに戻るをクリックしたら
    ページの反応がなくなりました。
    (リロードとタブを閉じることはできる、リロードすると元に戻る、
    一旦タブを閉じてから復元しても同様)


  • Community Manager

    @todo184184 @RwarqWAP @zyxwj ご報告・検証いただきありがとうございます。
    私では再現に至っておらず、今一度ご協力いただけると幸いです。

    次の再現手順・挙動認識で正しいでしょうか。
    (「セキュリティで保護されたページに戻る」をクリック時の挙動は一旦省略)

    1. 本スレッドに掲載されたhttps://skins.minecraft.netへのリンクをクリックする。
    2. ページが表示されたら、アドレス欄のセキュリティアイコンからFlashをブロックする。
    3. ページを再読込する。

    正しい挙動:画面が正常に表示され、各種操作が可能。
    実際の挙動:画面が白紙になる。


  • Community Manager

    @zyxwj サポートありがとうございます!ご記載いただいた手順の2.で「真っ白なページが表示される→30秒ほど経過し、読み込みが完了する」事象が発生いたしました。報告挙げます。


  • Community Manager

    @zyxwj と、思いましたが、Chromeでも発生いたしました。Chromiumでも再現するかと思われますが、いかがでしょうか。手元のMac 67.0.3393.0で確認したところ、再現いたしました。

    Chromiu65.0.3325.181で同様の手順を試しても再現しなかったのでVivaldiの不具合と思われます。


  • Community Manager

    @todo184184 @zyxwj

    Chromium側のレポートID292393のコメント#25に、本件と同様と見られる件の発言があります。
    https://bugs.chromium.org/p/chromium/issues/detail?id=299770#c25

    コメント#26でF5/BIG-IP(これのことかと http://e-words.jp/w/BIG-IP.html )側の不具合ということになっていますが...



  • @Takaaki @zyxwj
    ※4/9 23:50追記
    私の投稿した不具合が別の形で認識されているため、再度確認させてください。

    本スレッドに掲載されたhttps://skins.minecraft.netへのリンクをクリックする。
    1で開いたタブはそのままで、 再度 https://skins.minecraft.netへのリンクをクリックすると新規タブが白紙の状態で固まる

    上記では初回アクセスが成功した後に別タブを開き再度アクセスしていますが、
    私の環境では「初回アクセス時にて真っ白なページが表示される」という事象が起きております。
    この事象はいまのところvivaldi以外では確認していないのですが、それを踏まえて下記URLの不具合ということですか?

    Chromium側のレポートID292393のコメント#25に、本件と同様と見られる件の発言があります。
    https://bugs.chromium.org/p/chromium/issues/detail?id=299770#c25
    コメント#26でF5/BIG-IP(これのことかと http://e-words.jp/w/BIG-IP.html )側の不具合ということになっていますが...

    0_1523284349060_test-iloveimg-compressed.gif


  • Community Manager

    @todo184184 もとのご報告と認識が合致していないまま進んでしまい、申し訳ございません。さきほど、手元のWin10 64bit Vivaldi 1.15.1150.1(内部開発用ビルド)で下記の現象が発生したため、共有いたします。

    【再現手順】

    1. 未使用のプロファイルでVivaldiを開く。(つまり拡張機能やskins.minecraft.netの閲覧履歴はなく、ブラウザーもデフォルト設定の状態)
    2. アドレス欄に、https://skins.minecraft.net と手入力し、Enterを押下。

    【期待される挙動】
    プライバシーエラーのページが表示される(一番目に添付頂いた画像と同様)

    【実際の挙動】
    プライバシーエラーというページタイトルのページが表示されるが、中身は白紙(二番目に添付頂いた画像と同様)



  • @Takaaki
    ご確認頂きありがとうございます。
    共有頂いた事象で間違いございません。


  • Community Manager

    @todo184184 本件修正入り次第、こちらにてご連絡いたします。取り急ぎ。



  • @takaaki said in 証明書失効サイトにアクセスするとページがクラッシュしてしまう:

    @todo184184 もとのご報告と認識が合致していないまま進んでしまい、申し訳ございません。さきほど、手元のWin10 64bit Vivaldi 1.15.1150.1(内部開発用ビルド)で下記の現象が発生したため、共有いたします。

    【再現手順】

    1. 未使用のプロファイルでVivaldiを開く。(つまり拡張機能やskins.minecraft.netの閲覧履歴はなく、ブラウザーもデフォルト設定の状態)
    2. アドレス欄に、https://skins.minecraft.net と手入力し、Enterを押下。

    【期待される挙動】
    プライバシーエラーのページが表示される(一番目に添付頂いた画像と同様)

    【実際の挙動】
    プライバシーエラーというページタイトルのページが表示されるが、中身は白紙(二番目に添付頂いた画像と同様)

    こちらは再現しました。
    なお、既に他のページを開いているタブでやると元のページの内容が
    表示されたままになってしまうようですね。

    @zyxwj

    セキュリティで保護されたページに戻るをクリックしたら
    ページの反応がなくなりました。

    こちらは無条件に再現しますね、安定版の1.14.1077.60でも確認しました。

    あと、こちらも再現するようなら修正お願いします。


  • Community Manager

    @todo184184 @zyxwj @rwarqwap
    本件、後ほど公開予定の1.15.1147.29にて解消される見込みです。よろしければご確認よろしくお願いいたします。



  • @takaaki

    本件、後ほど公開予定の1.15.1147.29にて解消される見込みです。よろしければご確認よろしくお願いいたします。

    直ったかに思えたのですが https://skins.minecraft.net/ を新規タブで
    開いて (履歴がない状態)、セキュリティで保護されたページに戻るを
    クリックしたら反応がなくなる問題は直っていないようですね。
    (既存のウィンドウからアドレスバーに入力して移動した場合は正常に
    前のページに戻る)

    確認はしていないのですがもし、Chrome でも再現するようなら Blink 側の
    不具合という事で Vivaldi では修正不可という事でしょうか。
    それなら仕方ないと思いますが。



  • @Takaaki
    私の報告した不具合が解消されているのは確認できました!
    ご対応頂きありがとうございます。

    直ったかに思えたのですが https://skins.minecraft.net/ を新規タブで
    開いて (履歴がない状態)、セキュリティで保護されたページに戻るを
    クリックしたら反応がなくなる問題は直っていないようですね。

    ただ、上記で @RwarqWAP さんが報告してくださった現象については
    chromeとvivaldiで差異があるため、ご確認いただけますでしょうか。

    ■「セキュリティで保護されたページに戻る」を押下(新規タブかつ履歴がない状態)

    vivaldi:1.15.1147.29 (公式ビルド) (64-bit)
    0_1524271792859_test1.png

    chrome:66.0.3359.117(Official Build) (64 ビット)
    0_1524271902537_test2.png


  • Community Manager

    @rwarqwap @todo184184 おっしゃる通り、私の手元でもChromeとの差異が確認できました。社内でも報告いたします。


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.