Startup Password



  • On startup of the first instance of Vivaldi I am challenged for my system password, even though I have that feature turned off in my system and I am not challenged on startup of my computer. How to turn that off please. Thank you.

    Linux Mint 18.3 Cinnamon 3.6.7


  • Moderator

    Check:

    Kwallet: ~/.kde/share/apps/kwallet/* ---- ~/.kde/share/config/kwallet*

    or

    GNOME keyring: ~/.local/share/keyrings/* :



  • @lamarca Check what exactly? /.local/share/keyrings has two files:

    login.keyring
    user.keystore

    I double checked and I do have automatic login enabled in my system settings so there is no login window when I startup the computer.


  • Moderator

    @llewellen said in Startup Password:

    On startup of the first instance of Vivaldi I am challenged for my system password

    Vivaldi is getting a keyring request.
    As you mentioned ~/.local/share/keyrings/*.keyring - That's the Gnome. Open the terminal and issue the following command:

    rm -v ~/.local/share/keyrings/*.keyring

    Restart your computer, when prompted for the damn keyring, click continue and leave everything blank.

    Let us know if worked for you.



  • @llewellen
    FYI
    The default keyring (login.keyring) uses the login password for encryption, so users don't need to remember another password.
    This keyring is unlocked when you manually login.
    When using automatic login, the keyring is not unlocked at login so vivaldi prompts to unlock the keyring for password saving.
    Nothing wrong with removing the login.keyring and setting no password as shown by @lamarca but be aware that
    if you save passwords within vivaldi they will be stored unencrypted.

    I usually recommend to just turn off automatic login but it depends how you use your computer.



  • @cantankrus I'm the only person who ever has access to my laptop - unless it was stolen or lost. In that case, I definitely DO NOT want unencrypted passwords in Vivaldi (I use that a lot). I'm going to disable the system Automatic Login.



  • @lamarca Thank you for this but as cantankrus has pointed out, that would leave my computer wide open and any passwords I store in Vivaldi would be unprotected. I will put up with the annoyance of a password challenge when I fire up my laptop each day.



  • @llewellen said in Startup Password:

    I will put up with the annoyance of a password challenge when I fire up my laptop each day

    It's not really that burdensome IMO. The prompt does not arise from booting the pc nor logging into the Plasma desktop [oh, whoops, i just realised you're using Cinnamon not KDE, so maybe yours behaves differently], but only when launching Vivaldi itself. Thereafter for the rest of the day there's no disturbance, & indeed, coz i Sleep my PCs at night not shut them down, in practice it is usually several days or even a week between V launches, ie, between password prompts.


  • Moderator

    @llewellen You're welcome. Prefs are prefs.
    There's been a long time my login is manually, however the Chromium code shows the pwd in plain text.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.