Text in input fields sometimes enters backwards



  • I noticed that when I erase some text in a one line text input field, when I try to type in different text it goes in right to left. I can't actually backspace text when this happens, I have to actually use the Delete key instead and carefully enter the text in reverse order. I don't know what causes this and it only happens in Vivaldi. If this is an option I can't find it to turn it off.


  • Moderator

    Accidentally typed strange shortcuts?
    If you are in a text field which has the incorrect writing direction, use context menu and switch back to Left to Right.

    I can not see where a textfield reacts to Backspace as like Go Back in History.
    That was fixed months or longer ago.

    Where does this happen with which Vivialdi version?



  • I discovereed what causes this and I'm positive its a bug. this is the latest stable version

    If you click and drag across a text field from the right to the left to select all text so you can delete it, any new text you enter will go in backwards, but the cursor stays on the left edge. So you can't backspace because there's no text on the left of the cursor. This happens until you click outside the text box.

    Also while I was writing this post Vivaldi just suddenly closed without any warning or error message. This only happens on the latest version too. How can I rollback to the last version?


  • Moderator

    @cpd Are you using any extensions?



  • It happens even in private browsing without any extensions active.


  • Moderator

    @cpd I can't seem to find any way I can reproduce it here. All of my text entry is as expected, irrespective of conditions or prior actions.


  • Moderator

    @cpd Have you applied any extensions or non-standard settings to your desktop environment?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.