Spell Check



  • This evening I downloaded Vivaldi, I can't find spell check, web info says I can get it from Chrome store for Vivaldi, but no luck figuring how to do that after an hour wasted trying! No icon for apps or add-ons! I'm dyslexic, so no spell check is a deal breaker!


  • Moderator

    @sandib Spell check is built in. I have it, and never had to install or activate it. What are you looking for?


  • Moderator

    @sandib Right-click in a text area such as this message reply box, to show the spell-check submenu.

    Visit the Language Settings to add more dictionaries.

    0_1522186310153_Language Settings.png

    Expand the Languages drop list and click on Add Languages at the bottom, where you can choose any available Hunspell dictionary.

    0_1522186613542_Add Language.png



  • @ayespy Hi, I have just realised spell check is built in! Wonders never cease, I must have spelled everything correctly all evening lol. When I right click I did not get spellcheck options, I get the dialog box posted in the pic.
    0_1522188684945_spel.png image url)


  • Moderator

    @sandib said in Spell check:

    When I right click I did not get spellcheck options, I get the dialog box posted in the pic.

    Then you did not right-click in an edit box, but on the page.


  • Moderator

    @sandib Yes. You have to click in a textbox you are typing in to get the spellcheck options - not a textbox posted by someone else.



  • Spell check doesn't work again.



  • @marcus2083
    EDIT: It seems that I shouldn't comment before I had my first coffee -.-' sry see the comment from @Pesala below
    Spellcheck does work but the thing that does not work is the option settings as far as I can see it. Correcting options are presented in the up most part of the right click menu on a wrong word but I got no options to change the language for spell check.
    tested with viv 1.16.1170.3 (32bit) win 7 (64bit)


  • Moderator

    @marcus2083 said in Spell check:

    Spell check doesn't work again.

    When reporting issues, please give your OS and Vivaldi version number. Also be more specific. What does not work?

    Spell-check is working fine here in both Vivaldi 1.15 final (clean install) and my default Vivaldi 1.15 Snapshot.

    0_1525763066823_Spell Check.png


    Specs: AMD A10-6800K, 8 Gb on Win 10 64-bit •Snapshot 1.16.1170.3 (64-bit)


  • Moderator

    @zaibon said in Spell check:

    I got no options to change the language

    That's because you have an incorrectly spelled word selected. After changing the language, the word might be correct, so you should change the language, then make corrections.



  • I have spell check, but cannot add a new language or switch the spell check language. I can change the app UI language, but that doesn't change the spell checker language. here is a screen shot of my right menu context when selecting a 'wrong' word (different language).example

    I would like to keep the UI in English and enable spell check for other languages. Any help is appreciated, @Pesala and other knowledgeable people. Thank you!
    Version: 1.15.1147.36 (Stable channel) (32-bit), standalone install.


  • Moderator

    @9000 Please read the thread. All the answers that you need are given above.



  • @pesala said in Spell check:

    That's because you have an incorrectly spelled word selected.

    For those who will read this in the future, this was the problem. Strangely enough, the "Spellcheck" option doesn't appear in the context menu when right clicking the 'misspelled' word, exactly when you realize you are writing in a different language and need to add a new one for spell checking. When I click on the SAME text field but without selecting any word, the menu entry is there. That's a Chromium issue, my other browsers have the same problem, and this is the first time I noticed it, because despite having been using other Chromium flavors for many years, in those other browsers the add language option is present in the Settings page, whereas here it was left out of the stylized options (here you have a direct link to the native settings, or copy and paste this: vivaldi://settings/languages)

    Thank you, @Pesala



  • @9000 said in Spell check:

    here you have a direct link to the native settings

    Right click menu is missing "Spellcheck" for me. There is "Language settings" which takes me to vivaldi://settings/languages and I have all the languages I'm using there. However I'm not getting spelling errors for non-English languages.

    Any suggestions?



  • Just an FYI I've never seen spell check work for me either.

    When trying just now it seems the corporate firewall is blocking the download of dictionaries. I had (at some point) specified English (not US) as a language so I selected that as the default language and all my Vivaldi user settings were reset - scary! Luckily, closing and re-opening brought things back to normal but now I still can't select "English" (greyed out switch) or "English (United States)" (download failed).

    But I don't think it's only the firewall... It's never worked for me at home either. I will try to remember to look at it there again soon



  • So now I'm using the home laptop and the spell checker seems to be working after all.

    So either I was mistaken or it doesn't / didn't work on one of my other PCs. Never mind...



  • @lamarca I know that 🙂 - I was replying to the screenshots from @nelov where "Spellcheck" was NOT in the context menu (to allow switching between languages).


  • Moderator

    @tbgbe Oops. I read your reply only.....


  • Moderator

    @9000 While on a misspelled word you cannot switch the spell language. Same as in other browsers.


  • Moderator

    It happens in some OS

    vivaldi://settings/languages

    replace for

    chrome://settings/languages

    And you will solve the issue


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.