[SOLVED] [1.15.1132.3 ] Vivaldi doesn't save any passwords anymore



  • Hi there,

    the last 4 - 5 hours I spent to solve some really big passwords issue in Vivaldi. I searched around here in the forum and via Google, but unfortunately nothing did work and it drives me crazy!

    The problem:
    Suddenly there is no pop up to save a password after log in on a site.
    I cleared all passwords, cache and cookies, I even de-installed and re-installed first the snapshot and then even the stable version. I already tried a profile reset and started with a fresh profile.
    Nothing changed and the password pop up still doesn't work.

    Till this afternoon it used to work fine, but I had to delete a password, because I had to change it and Vivaldi didn't ask to save the new password.

    I'm using Kubuntu 16.04 and Vivaldi 1.15.1132.3 snapshot (64-Bit) and having Kwallet running and showing that it is connected to Vivaldi.

    I also checked at vivaldi://settings/passwords and it shows no saved passwords anymore.

    Anyone has any suggestions to solve this issue? It gets really anoying...

    EDIT 1:
    I did a bug report: VB-38938 "Vivaldi snapshot doesn't save any passwords anymore"
    I don't know why, but I got a second confirmation of the bug report: VB-38939

    EDIT 2:
    I recently installed again the stable version ( Vivaldi 1.14.1077.60 (64-Bit)).
    The pop up seems to work there now. But why does it not work in the snapshot anymore?!

    Thank you in advance,
    Chipy

    [modedit] Added version number to title


  • Moderator

    @chipy Confirmed. (VB-38938 & VB-38939).
    Build 1.15.1136.7-1



  • @chipy said in Vivaldi doesn't save any passwords anymore:

    I'm using Kubuntu 16.04 and Vivaldi 1.15.1132.3 snapshot (64-Bit)

    Um, that's 5 hours & the loss of your sanity that you could have avoided simply by reading the Snapshot blog post when it was released 5 days ago:

    0_1526715521187_Known Issues.png


  • Moderator

    @steffie We don't run the same Snapshots, recently there was a similar bug, the password dialog did not prompt only on fullscreen mode, fixed.



  • @lamarca My reply was not to you, it was to the OP, whose own words [that i quoted] showed that they did indeed run the SS version i referenced.


  • Moderator

    @steffie said in Vivaldi doesn't save any passwords anymore:

    @lamarca My reply was not to you, it was to the OP, whose own words [that i quoted] showed that they did indeed run the SS version i referenced.

    Forum is a place to discuss and exchange ideas.
    If you think my participation violated any rule, in the [โ‹ฎ] there is an option: "Flag This Post For Moderation", feel free to use it.
    Otherwise don't say who are able or not to join the discussion.



  • @lamarca Huh? I said or thought none of those things, only that your previous post to me implied you erroneously thought i was replying to you, which i was not. Merely by me re-clarifying that fact was not an attack on you. In fact, until you replied to me i was not talking to you at all, only with the OP. My basic points stands; OP self-admitted spending 5 hours trying to solve a problem that the Devs clearly publicised as having that bug. OP & that blog post are associated with the same SS version.


  • Moderator

    @chipy said in Vivaldi doesn't save any passwords anymore:

    But why does it not work in the snapshot anymore?!

    It is a known issue and was already post in Snapshot blog.
    You missed to read it?


  • Moderator

    I closed your bugreports as duplicates of VB-38805.



  • Wow, wow, wow! Incredible!
    I never imagined to get so much replies regarding my issue and I never meant to get others to fight because of that stupid issue.

    @lamarca said in Vivaldi doesn't save any passwords anymore:

    @chipy Confirmed. (VB-38938 & VB-38939).
    Build 1.15.1136.7-1

    Lamarca, you were the first one to calm me down and letting me know after all the senseless spent hours that also others have this issue. Shared pain is half of the pain. ;)
    But if you're talking about Build 1.15.1136.7-1 and I'm having 1.15.1132.3 - so this means, it can take a long time to solve this issue?

    @steffie & @gwen-dragon:

    My basic points stands; OP self-admitted spending 5 hours trying to solve a problem that the Devs clearly publicised as having that bug. OP & that blog post are associated with the same SS version.

    It is a known issue and was already post in Snapshot blog.
    You missed to read it?

    I feel so stupid right now. :(
    Both of you are totally right. I missed to read that line in the blog... :/

    It's really a pitty about the lost time yesterday, but you have to see something positive in everything. So I'm taking it with humor: I'm feeling like a real developer who discovered an issue and tried to fix it somehow. :D

    @gwen-dragon said in Vivaldi doesn't save any passwords anymore:

    I closed your bugreports as duplicates of VB-38805.

    Thanks, @Gwen-Dragon.
    Can we say how long it could take to solve that issue?!

    Thank you to everyone for supporting me in this hard times living with this issue.

    Regards,
    Chipy


  • Moderator

    The time difference between VB-38938 and VB-38939 is one sec. It does not sound good.



  • @lamarca said in [1.15.1132.3 ] Vivaldi doesn't save any passwords anymore:

    The time difference between VB-38938 and VB-38939 is one sec. It does not sound good.

    I don't how and why it was sent twice...


  • Moderator

    @chipy Software.



  • @lamarca said in [1.15.1132.3 ] Vivaldi doesn't save any passwords anymore:

    @chipy Software.

    What exactly do you mean?



  • The newest snapshot version 1.15.1146.5 successfully fixes this issue!

    Thank you, devs! ;-)


  • Moderator

    Cheers:)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.