Installing Extensions Makes Browser *Appear* To Hang



  • Attempting to install extentions, I see the browser "hang" after the "Add to..."/status button changes to "checking..". Minimizing/Restoring the browser window appears to make it functional again (but of course doesn't actually install the extension).

    It seems that what's actually happening is there's some hidden modal dialog that should be visible, asking a question about the extension (Cisco WebEx Extension, in my testing). But, the dialog is invisible.

    If I use the left-cursor key and hit enter to blindly accept whatever yes/no dialog should have been shown, the extension installs fine.

    Vivaldi 1.14.1077.60 (Stable channel) (64-bit)
    Revision 44919e4fea5e7e6a209f00d1780f799bf211e559-
    OS: Ubuntu 18.04 (bionic) + KDE Plasma 5.12


  • Moderator

    I suggest you to contact the extension author.



  • @3vi1 said in Installing Extensions Makes Browser *Appear* To Hang:

    Cisco WebEx Extension

    The extension installs without problems for me. The dialog you are talking about is asking about permissions and every extension does this – therefore if this installation fails for you, every installation should fail on the chrome webstore.

    I would disable all adblockers/extensions you have running and try again with a rather clean Vivaldi. But read the reviews, seems like the extension doesn't work anyway on Linux, since it relies on Java.



  • Oh - I only see this now!
    I had the same issue, it's not related to specific extensions, for me it happened for any one I wanted to install, and even for uninstalling one from vivaldi://extensions/.
    For me, this happened at the office. When I tried again later at home it worked without problems. Next day at office - same problem again.
    I thought it had been some network filter on our university network, but looking at tcpdump output I could not spot any packages that seemed to not reach the other side (and I had disabled all extensions before trying)
    No idea what 'checking' actually involves - but obviously the google server was unhappy and did not reply.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.