Moving a Vivaldi window between 2 screens causes a cursor offset



  • I cannot remember when this issue started, but here is the issue.

    When I move a Vivaldi window between my 2 displays(1920 x 1080 and 1600 x 900), the cursor is no longer hovering where it should be.

    When the browser is moved from the 1600 x 900 display to the 1920 x 1080 display and you are on YouTube and the cursor is over "Purchases", it is highlighting "History" and if you attempt to click history to open it, nothing will happen.

    And when on this forum, when i hover over "Popular" on the navigation bar, it highlights "Tags"



  • @aneil1998 What happens when you open a new window on the second screen, select all tabs in the window of the first screen, right-click and hover "Move Tab to" and move these tabs to the window on the second screen?



  • @luetage When I move the tabs between each window, they work how they're supposed to.



  • @aneil1998 File a bugreport for this issue and use the tab-moving as a workaround until this is fixed.

    https://vivaldi.com/bugreport/


  • Vivaldi Ambassador

    This is happening to me as well. I'm on 1.15.1147.36 (Stable channel) (64-bit), and moving between a 1920x1080 at 100% scaling, and a monitor of 2560x1440 with 125% scaling.

    I noticed something else interesting: If the window is originally opened on "Screen 1", moving it to "Screen 2" breaks all the existing tabs. But any new tabs created while the window is on "Screen 2" work normally -- but then, moving the window back to "Screen 1" breaks whatever tabs were newly created on "Screen 2".


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.