Vivaldi unter Debian stable: GPU-Einstellungen



  • Hallo,

    ich bin neu hier und habe gleich auch ein Problem. Vivaldi scheint unter Debian Stretch (stable) nicht richtig rund zu laufen, besonders bei Html5-Videos, da ruckelt es manchmal, besonders am Anfang. Ich habe eine Notebook-Grafik (Nvidia Geforce 940m) und habe den Treiber der Herstellerseite installiert. Dazu muss ich hinzufügen, dass das Notebook zwei Grafikkarten hat, eine integrierte Intel- und eine zweite Nvidia-Karte. Seit kurzen nutze ich die Nvidia-Karte dauerhaft. Da hat das Ruckeln angefangen. Nun habe ich bei den GPU-Einstellungen unter vivaldi://flags einiges geändert, d. h. ich habe alles auf "enabled" gesetzt. Die Videos ruckeln nicht mehr so toll und unter vivaldi://gpu wird auch eine Hadrware-Beschleunigung angezeigt. Allerdings scheint der Browser jetzt instabil geworden zu sein, d. h. nach dem Aufrufen einer Google-Seite sind die Tabs plötzlich schwarz geworden, nach einem Neustart war alles wieder in Ordnung. Ist das ein Bug, oder habe ich da an einigen Schrauben gedreht, die ich besser wohl nicht angefasst hätte? Ich könnte den Browser wieder zurücksetzen, aber dann ruckeln die Videos wieder.



  • @rainer22
    Hi, mit meiner GM965 Intel GPU auf Uralt Laptop ruckelt nichts.
    Deine GT 940m ist, im Vergleich, extrem Leistungsfähig.
    Du kannst mal probieren:

    1. Wie sieht der obere bereich von vivaldi://gpu aus?
    2. Wird deine CPU bei Video ansehen belastet?

    So sieht das bei mir aus:
    Graphics Feature Status
    Canvas: Hardware accelerated
    CheckerImaging: Disabled
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Disabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Software only. Hardware acceleration disabled
    Video Decode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated

    Gruß, mib
    Opensuse Leap 42.3 x86_64
    CPU Intel T4200 4 GB
    GPU Intel GN 965
    xf86-video-intel 2.99.917-6.1
    KDE Plasma 5.8.7
    1.15.1111.3 (Official Build) snapshot (64-bit)



  • Danke für die Antwort. Hier die oberen Zeilen von vivaldi://gpu:

    Graphics Feature Status
    Canvas: Hardware accelerated
    CheckerImaging: Disabled
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Hardware accelerated
    Video Decode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated
    Driver Bug Workarounds
    clear_uniforms_before_first_program_use
    disable_discard_framebuffer
    disable_framebuffer_cmaa
    force_cube_complete
    init_gl_position_in_vertex_shader
    init_vertex_attributes
    pack_parameters_workaround_with_pack_buffer
    scalarize_vec_and_mat_constructor_args
    unpack_alignment_workaround_with_unpack_buffer
    unpack_overlapping_rows_separately_unpack_buffer
    use_virtualized_gl_contexts
    Problems Detected
    Program link fails in NVIDIA Linux if gl_Position is not set: 286468
    Applied Workarounds: init_gl_position_in_vertex_shader
    Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    Linux NVIDIA drivers don't have the correct defaults for vertex attributes: 351528
    Applied Workarounds: init_vertex_attributes
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    MakeCurrent is slow on Linux with NVIDIA drivers: 449150, 514510
    Applied Workarounds: use_virtualized_gl_contexts
    NVIDIA fails glReadPixels from incomplete cube map texture: 518889
    Applied Workarounds: force_cube_complete
    Pack parameters work incorrectly with pack buffer bound: 563714
    Applied Workarounds: pack_parameters_workaround_with_pack_buffer
    Alignment works incorrectly with unpack buffer bound: 563714
    Applied Workarounds: unpack_alignment_workaround_with_unpack_buffer
    Framebuffer discarding can hurt performance on non-tilers: 570897
    Applied Workarounds: disable_discard_framebuffer
    Unpacking overlapping rows from unpack buffers is unstable on NVIDIA GL driver: 596774
    Applied Workarounds: unpack_overlapping_rows_separately_unpack_buffer
    Use GL_INTEL_framebuffer_CMAA on ChromeOS: 535198
    Applied Workarounds: disable_framebuffer_cmaa
    Disable KHR_blend_equation_advanced until cc shaders are updated: 661715
    Applied Workarounds: disable(GL_KHR_blend_equation_advanced), disable(GL_KHR_blend_equation_advanced_coherent)
    Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
    Disabled Features: native_gpu_memory_buffers
    Checker-imaging has been disabled via finch trial or the command line.
    Disabled Features: checker_imaging

    Obwohl ich alles auf "enabled" gestellt fällt mir die drittletzte Zeile auf.



  • Ich wollte nur hinzufügen, dass die wenigen Ruckler, die ich jetzt noch habe, wahrscheinlich von meiner Internetverbindung kommen. Es passiert meistens bei Kamerafahrten. Ich habe 18 Mbit, wenn ich das richtig ausgerechnet habe, und die Videos sind automatisch auf HD gestellt.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.