Pc never goes to sleep if Vivaldi is left open



  • As the title says - whenever I forget to close Vivaldi before I leave home, the pc never goes to sleep and is still awake when I come back. (powercfg /lastwake shows 0 wakes meaning the system never went to sleep)

    If I close Vivaldi pc goes to sleep as expected.

    Using 1.14.1077.55 (Stable channel) (64-bit) of Vivaldi.

    (on unrelated note I still cannot post without having to turn my vpn (PIA) off, with Akismet claiming "spam detected" when it's on)


  • Moderator

    @sammael Which extensions are you running?



  • @pesala Hi, I am using following extensions:

    Authy 2.5.0
    Checker Plus for Gmail™ 21.1.2.1
    chromeIPass 2.8.1
    Google Translate 2.0.7
    Pushbullet 339
    Search by Image (by Google) 1.5.2
    Tampermonkey 4.5
    uBlock Origin 1.15.2
    uBlock Origin Extra 2.63
    View Image 1.9.2

    Tampermonkey only runs one userscript that is only active on youtube, no youtube tabs are opened when the pc is not falling asleep.


  • Moderator

    @sammael Checker-plus for Gmail looks like a likely culprit. Try disabling that, then set your PC to sleep.

    If it's not that, disable each of the others until you find the one that's running in the background.



  • @pesala Thanks for the suggestion, I will try disabling the extensions when I get home from work tonight.



  • I turned extensions off and the pc went to sleep so it is one of the extensions, I'm not gonna investigate which though as turning any of them off is not an option for me. I will just have to remember to close Vivaldi.


  • Moderator

    @sammael If it is only the Gmail checker, then why not turn it off before sending the PC to sleep, then turn it on again when you resume work. It should be easy to do from the Extensions bar.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.