Video problems



  • As of now this is the only setback for Vivaldi browser as far as i'm concerned, i've managed to work around many issues with the help of the Forums but i'm not sure if its possible to fix this inside Vivaldi. Basically, Twitter Videos do not open at all or auto play, some YouTube videos show a black screen and don't play. Is there a fix for any of this?



  • It should work, if you run vivaldi by hand you can get debugging and that should give a hint as to what the issue is. (Stolen from an old post):
    Run vivaldi from the terminal (command prompt) with --enable-logging --v=1
    chrome_debug.log will be created in a user data folder.

    In linux it is : /home/MYUSER/.config/vivaldi-snapshot/chrome_debug.log



  • The command is not working for me...........



  • Here's how the video shows on Twitter...

    alt text

    And YouTube...

    alt text


  • Vivaldi Translator

    @nickparkermusic : I am on Mac and have the same issue. Please, see my profile and find my posts about the User-Agent. I use an extension to change the UA, and I am able to play the twitter videos by simply changing the UA to iPad and back to my default. This way twitter medias do play.

    @srart : We are on UNIX-driven OS, not *nix. All codecs are present, even flash pappi is. Vivaldi for Mac is still rough product. Currently the browser developers are trying to ‘hack’ the UA by entering a higher version #, but on Mac this is a dead-end: most media do not play. I’ve proposed a custom UA string that seems to work in most cases, except for twitter, but using the same UA switcher extension it is still possible to make them play even using the current SS of Vivaldi for Mac.



  • @zmeypc said in Video problems:

    @nickparkermusic : I am on Mac and have the same issue. Please, see my profile and find my posts about the User-Agent. I use an extension to change the UA, and I am able to play the twitter videos by simply changing the UA to iPad and back to my default. This way twitter medias do play.

    @srart : We are on UNIX-driven OS, not *nix. All codecs are present, even flash pappi is. Vivaldi for Mac is still rough product. Currently the browser developers are trying to ‘hack’ the UA by entering a higher version #, but on Mac this is a dead-end: most media do not play. I’ve proposed a custom UA string that seems to work in most cases, except for twitter, but using the same UA switcher extension it is still possible to make them play even using the current SS of Vivaldi for Mac.

    I really hate sorting this out with yet another extension. One of my main reasons to use Vivaldi is not needing extensions to do most of the tasks I look for in a browser. I really don't trust Chrome extensions so I have to do some extensive research first before getting a UA changer. I hope they sort it out in coming updates.


  • Vivaldi Translator

    @nickparkermusic : by changing the default UA as described in my previous posts, you will resolve your YT issues. I do propose to use a Safari-like UA. Please, do note that you have to check your Safari and change it accordingly. There is another YT issue: their new design. I hate it. I am never logged in. And a week ago they made a change not allowing to revert YouTube to the old design. I suggest the same method: suppose you got your UA as your Mac OS X build # is set, the Safari version #, and the WebKit #… then you change this modded UA to another let’s say a mobile one (iPad) and back again quickly to the modified (OSX/Safari/Webkit). In most cases it will show you the old design. AGAIN: 1) UA is Safari-modded one: YT shows the new design only; 2) Change the UA to Mobile (iPad) or to Chrome for Mac, and then back to the Safari-modded UA should show the YT in its old design…

    NB Trying to add the Vivaldi version # or the Chrome version # always block YT from working. Cheers!


  • Vivaldi Translator

    @nickparkermusic said in Video problems:

    I really hate sorting this out with yet another extension. One of my main reasons to use Vivaldi is not needing extensions to do most of the tasks I look for in a browser. I really don't trust Chrome extensions so I have to do some extensive research first before getting a UA changer. I hope they sort it out in coming updates.

    I am sorry bro. I do think like you do. use this page: https://www.esolutions.se/whatsmyinfo to fine-tune your UA in order to much your OSX/Safari/WebKit. It is the test-page of the extension I am using.



  • @nickparkermusic said in Video problems:

    I hope they sort it out in coming updates.

    If by "they" you mean Vivaldi devs, then they cannot sort it out.
    A user agent modification which works, shows that the problem is on the website and not in the browser.



  • Oh yes, I forgot Vivaldi is an inferior browser to some websites. I wonder why it's not registered as Chrome if it's already using Chromium engine?


  • Moderator

    Web sites encode their videos in different ways. Vivaldi currently uses the macOS platform libraries to play some video formats (such as H.264) and routes these media streams through the GPU process. This works well for most Macs out there. Unfortunately, Chromium started blacklisting some graphics drivers (and disabling hardware acceleration on affected systems) due to incompatibilities with their code, and this in turn partially broke video playback in Vivaldi on those Macs.

    If you click on vivaldi://gpu and it shows that hardware acceleration has been disabled, you won't be able to play some videos. There is a way to override the GPU blacklist, which would re-enable video playback, but could also cause other instabilities in the browser.

    The Vivaldi team is currently working on a fix for this issue so that the browser can once again play all supported video types, with or without hardware acceleration.



  • Thank you for the explanation @xyzzy

    @zmeYpc I gave in and Installed Chrome UA Spoofer it showed up as the top result and many seem to use it. The good thing is the videos work now the bad news is they UA resets when i restart Vivaldi or close the tab and reopen it. I'm not sure how to add custom settings but I saw that we can import/export the extension settings so If you don't mind sharing yours I'd be thankful to use them.


  • Vivaldi Translator

    @nickparkermusic: I am using User-Agent Switcher for Google Chrome. I gave you a link to its test page. Have you found/read my older posts on the matter? Using this ext. I have added a custom category and a custom UA string. Here is what seems logical to me. (I don’t share xyzzy's views). We have the OS X, our Safari browser and the WebKit. Our Safari does play all the media, while Vivaldi doesn’t perform well. If it is for the different user-agent string the latter is using, what can be made to produce a a custom UA string for Vivaldi? Well, here it is (I suggest you to check your Safari/WebKit) and first to borrow your Safari’s US string:
    Mozilla/5.0 (Macintosh; Intel Mac OS X 1X_X_X) AppleWebKit/XXX.X.X (KHTML, like Gecko) Version/X.X.X Safari/XXX.XX.X
    COMMENTS:
    Mac OS X 1X_X_X is your OS version.
    AppleWebKit/XXX.X.X is your WebKit version.
    Version/X.X.X is the 1st part of your Safari version number.
    Safari/XXX.XX.X is the second part of your Safari version number (the engine’s number).
    In order to get the proper values, please, enable Develop menu in Safari (Safari > Preferences > Advanced > Show Develop menu in menu bar) and then Go to Develop > User Agent > Other… (and copy the UA string that will be the default used). That’s it. Use it in Vivaldi via the extension.

    If you compare this UA string to the one that Vivaldi has, I am sure that you will understand what’s wrong with Vivaldi. These 2 items: Chrome/64.0.3282.170 Vivaldi/1.96.1111.3 are obsolete as they are responsible for our YouTube, twitter, facebook ... and/or many other media troubles.



  • @xyzzy Can you divulge any details about the fix that they are working on and when we might see it? I haven't been able to play H.264 video in Vivaldi on my Mac (with Intel HD 3000 graphics) for over a year now, and trying to use Vivaldi as my only browser is very hard as a result.

    I originally was able to get it working by overriding the GPU blacklist, but unfortunately that bandaid didn't work for very long.



  • This is still giving me problems even with UA switcher, i give up. As far as YouTube is concerned I use TubeG app, it uses way less GPU and CPU resources than Vivaldi when a video is playing and i can do without Twitter videos.


  • Moderator

    @shrinra I don't have any news but will try to find out where things currently stand.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.