Debian snapshot repo borked.



  • Err:14 http://repo.vivaldi.com/snapshot/deb stable Release
    404 Not Found
    Reading package lists... Done
    E: The repository 'http://repo.vivaldi.com/snapshot/deb stable Release' does no longer have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.



  • hello srart
    Release. machine here snapshot is updated with the following repository; uses the word "main" where yours has the word Release. could that be the difference?
    deb http://repo.vivaldi.com/snapshot/deb/ stable main



  • hello srart
    okay it happened this machine here as well. just harder to spot because the package is currently up-to-date. I think the error just shifted from snapshot to stable... so something is in the workings. wait and see. you will be up-to-date after a wait maybe. I will stick to, at this time, the wording for snapshot is "main" in the sources list. though the error message does use the word Release/ InRelease; it may have just changed. We do not set the repository, vivaldi does that. will watch for updates with You on this one. here is up-to-date.
    Has Your machine been away from upgrading? how old is your snapshot version?


  • Moderator

    My vivaldi.list:

    test@debby:~$ cat /etc/apt/sources.list.d/vivaldi.list 
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    deb http://repo.vivaldi.com/stable/deb/ stable main
    

    My vivaldi-snapshot.list

    test@debby:~$ cat /etc/apt/sources.list.d/vivaldi-snapshot.list
    ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
    # You may comment out this entry, but any other modifications may be lost.
    deb http://repo.vivaldi.com/snapshot/deb/ stable main
    


  • hello srart
    hello Gwen-Dragon . our list is equivalent. thanks for the example. If the 404 means,, knocking but not answering,, hopefully that is a signal that new snapshot is moving-in. possible? surprise us.


  • Moderator

    @i_ri When i tested minutes ago on my Debian 9 my apt worked and checked for repo data.



  • Thanks ! different zones? where get first updating zone?
    the Time is in the Weather. just.

    System:    Host: evi Kernel: 4.13.0-1-amd64 x86_64 (64 bit, gcc: 6.4.0) 
               Desktop: Fluxbox 1.3.5 info: xfce4-panel dm: lightdm Distro: VSIDO_x64 V-Ger V-Ger
    Machine:   System: HP Pavilion 061 product: RB042AV-ABA a1410y version: 0n31211CT101ALHEN00
               Mobo: Hewleet-Packard model: Alhena version: 1.0 Bios: American Megatrends version: 3.18 date: 08/17/2006
    Weather:   Conditions: 33 F (1 C) - Clear Wind: From the West at 9 MPH Humidity: 52%
               Pressure: 29.85 in (1011 mb) Wind Chill: 26 F (-4 C) 
               Location: Washington DC (US) Altitude: 12 ft 
               Time: March 14, 5:22 AM EDT Observation Time: March 14, 4:52 AM EDT 
    CPU:       Single core Intel Celeron D CPU (-UP-) cache: 512 KB bmips: 6665.31 clocked at 3332.658 MHz 
               CPU Flags: acpi apic bts cid clflush cmov constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 
               dts fpu fxsr ht lahf_lm lm mca mce mmx monitor msr mtrr nopl nx pae pat pbe pdcm pebs 
               pge pni pse pse36 sep ss sse sse2 syscall tm tsc vme xtpr 
    Graphics:  Card: Advanced Micro Devices [AMD/ATI] RC410 [Radeon Xpress 200/1100] bus-ID: 01:05.0 chip-ID: 1002:5a61 
               X.Org: 1.19.6 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1920x1080@60.00hz 
               GLX Renderer: llvmpipe (LLVM 5.0, 128 bits) GLX Version: 3.0 Mesa 17.3.6 Direct Rendering: Yes
    Network:   Card-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter 
               driver: 8139too ver: 0.9.28 port: b800 bus-ID: 02:05.0 chip-ID: 10ec:8139
               Card-2: ASUSTek USB-N13 802.11n Network Adapter (rev. B1) [Realtek RTL8192CU] 
               driver: rtl8192cu usb-ID: 001-003 chip-ID: 0b05:17ab
    Drives:    HDD Total Size: 30.8GB (14.3% used)
    Repos:     Active apt sources in file: /etc/apt/sources.list
               deb http://ftp.us.debian.org/debian/ sid main non-free contrib
               Active apt sources in file: /etc/apt/sources.list.d/vivaldi-snapshot.list
               deb http://repo.vivaldi.com/snapshot/deb/ stable main
    Info:      Processes: 116 Uptime: 1:48 Memory: 433.8/931.4MB Runlevel: 5 Gcc sys: N/A 
               Client: Shell (bash 4.4.18 running in xfce4-terminal) inxi: 1.9.14 
    herev@evi:~$ sudo apt update
    Hit:1 http://ftp.us.debian.org/debian sid InRelease
    Ign:2 http://repo.vivaldi.com/snapshot/deb stable InRelease
    Err:3 http://repo.vivaldi.com/snapshot/deb stable Release
      404  Not Found [IP: 151.139.236.192 80]
    Reading package lists... Done
    E: The repository 'http://repo.vivaldi.com/snapshot/deb stable Release' no longer has a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    


  • picked a coincidence time to write of it: now here is updated; less than hour later.

    herev@evi:~$ sudo apt update
    [sudo] password for herev: 
    Hit:1 http://ftp.us.debian.org/debian sid InRelease
    Ign:2 http://repo.vivaldi.com/snapshot/deb stable InRelease  
    Hit:3 http://repo.vivaldi.com/snapshot/deb stable Release
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    All packages are up to date.
    

    concludes success ; no updated snapshot vivaldi there.
    vivaldi moves quickly.
    now. whatever happens next.
    We hope srart gets the new snapshot first. !



  • @srart
    Was getting the same error but now appears to be fixed.


  • Moderator

    @i_ri Did you run

    apt-get clean
    

    PS: Please use code blocks (=with ``` in a separate line) next time.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.