How to prevent Vivaldi from opening a new browser window?



  • I sometimes click Vivaldi shortcut when it is already running. It will start a new browser window, which is disturbing.
    Before it came to the point where I have Vivaldi as my main browser, answering to "Home" keyboard button, I'd like to resolve this problem, else it will quickly grow into an annoyance.



  • @anrdaemon Various programs (like IE) that run on my system besides Vivaldi also open an additional instance each time a shortcut is clicked; others (like Opera) open a new tab in the already-open instance; while still other programs simply refocus to the already-opened instance (like Windows' system shortcuts). There seems to be no real standardization on this, which (to me at least) means that whatever behavior you prefer would probably best be sought by a feature request for some kind of a settings option for it to be included in Vivaldi:(https://forum.vivaldi.net/category/113/feature-requests).

    By always employing a shortcut on the Windows Task Bar, any open instance of anything is always simply refocused, otherwise the program is opened.



  • Since it opens URL shortcuts in an already running instance, I presume this is solvable, one way or another.
    I just want to know this way, so I can adjust shortcuts accordingly.



  • Ok, running

    "C:\Program Files\Vivaldi\Application\vivaldi.exe" -- "vivaldi:startpage"
    

    kind of works. But the address stays in the addressbar.
    Is there no other way?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.