Vivaldi crashing everytime on boot because of sync.



  • I tried the stable and snapshot. I just re-enabled sync after the reset and it boots fine, but then when the initial loading is done, it wants to sync and when that happens it crashes.

    When I enabled sync for the first time I did saw it syncing the bookmarks. Anyway to disable sync outside the browser?

    And where can I send a log for the developers to fix it?

    Linux Mint 18.3.


  • Moderator

    @sojiro84 Submit a Bug Report then when you receive the confirmation email, reply to it with the log file as an attachment.


  • Moderator

    Hi,

    What is your Vivaldi version?

    @sojiro84 said in Vivaldi crashing everytime on bootbecause of sync.:

    And where can I send a log for the developers to fix it?

    Check the Sync progress by typing on the Address Bar
    vivaldi://sync-internals

    Also, you can try start Vivaldi from shell. If Vivaldi does not crash it means there is something wrong in your installation:

    /usr/bin/vivaldi --user-data-dir="/tmp/VIV-TES"
    or
    /usr/bin/vivaldi-snapshot --user-data-dir="/tmp/VIV-TES"



  • Thanks for the info all! I managed to boot Vivaldi in the meantime by deleting the sync folders in my profile. It generated new files and it works again.

    Haven yet entered my secure password yet to start sync again though.


  • Moderator

    @ ALL: If you sent a bugreport and Sync is running now for you, please reply to the bug report mail and write that the issue is resolved now for you. So we can close the bug.



  • Quick question; on my other machine, a laptop, I want to try and let is sync as well. It is also running Linux Mint 18.3.

    Only, there it is forever stuck on signing in. Deleting the 2 sync folders doesnt help.

    What file do I need to edit or remove for sync to forget that it was enabled?


  • Moderator

    The first login might take a bit time. Did you try in different times?



  • @lamarca said in Vivaldi crashing everytime on boot because of sync.:

    The first login might take a bit time. Did you try in different times?

    The browser on the laptop is still in the state from a few day's ago, before the big reset happened. Laptop didnt get the note that I need to sign in fresh again for a new sync setup.

    I also tried it multiple times and let it try for 10+ minutes with no luck. Somewhere there is still some sync data leftover that I need to delete so I can try again.


  • Moderator

    @sojiro84 said in Vivaldi crashing everytime on boot because of sync.:

    Laptop didnt get the note that I need to sign in fresh again for a new sync setup.

    In case you are talking about the other device, it's required to fill the username, password ans the encrypted password.
    On Main Menu >> Tools >> Settings >> Privacy, on Passwords, check if it's present the string vivaldi://sync-setup



  • @lamarca said in Vivaldi crashing everytime on boot because of sync.:

    @sojiro84 said in Vivaldi crashing everytime on boot because of sync.:

    Laptop didnt get the note that I need to sign in fresh again for a new sync setup.

    In case you are talking about the other device, it's required to fill the username, password ans the encrypted password.
    On Main Menu >> Tools >> Settings >> Privacy, on Passwords, check if it's present the string vivaldi://sync-setup

    I did that as well before I went to bed. Unfortunately that did not help. I also disconnected the internet while it was syncing but no luck there and my laptop was sleeping this night and when I resumed this morning it still was trying to sign in for syncing.

    Do you know where the sync settings are stored? The browser way doesn't work so we need to edit/delete some files for the browser to forget this syncing state.

    I already disabled and enabled sync in vivaldi://experiments and deleted the 2 sync folders in the profile directory (which are still gone), but there is still a setting somewhere that I missed.


  • Moderator

    The issue is on the second device, confirm?
    Deleting folders won't help. First the login must be completed on the second device.

    Have you tried the suggestion above: #3

    @sojiro84 said in Vivaldi crashing everytime on boot because of sync.:

    Do you know where the sync settings are stored?

    No, I don't



  • Well, I installed the snapshot and copied over my settings by manually setting it up and comparing it to the old one.

    Clean profile with the snapshot syncs. Seems the old profile wa broken. It was a version 1 launch day profile that I kept from my Windows day's.


  • Moderator

    Issue solved?


  • Moderator

    In case you didn't read: https://vivaldi.com/blog/sync-status-update/ - the 3rd paragraph


  • Moderator

    I can confirm sync crash on Mint 18.3 with Snapshot 1.15.
    I had to rm -fr .config/vivaldi-snapshot/Default/Sync\ * and start Vivaldi once more to get rid of the crash.

    Looks like bug VB-38402 "Crash after trying to load empty sync data"
    I confirmed it.


  • Moderator

    I don't experiment crash loop when syncing, but it seems the --disable-sync command line switch is working to start Vivaldi with Sync disabled, so it could help in this case ๐Ÿ™‚



  • Hi, after sync on a client system I got crash after open Vivaldi every time.
    I reset profile, sync and lost all my settings and speed dial thumbs, custom and regular.
    I delete Topsite files and now I have black thumbs.
    There is no other way as to use custom thumbs, reload button or open the page donยดt work. Argh.
    Is there a way to get thumbs in a clean state?

    Thanks, mib



  • @mib2berlin If I understand you correctly, you want to refresh the speed dials right? You also mention something about custom thumbnails.

    I can't help with the latter, but if you want your speeddial websites to show a preview, you can do that in the bookmark list in the new tab page.

    Select the folder that you want to refresh the icons for and press "Refresh thumbnails" button to reload the thumbnails for that site.

    @gwen-dragon said in Vivaldi crashing everytime on boot because of sync.:

    I can confirm sync crash on Mint 18.3 with Snapshot 1.15.
    I had to rm -fr .config/vivaldi-snapshot/Default/Sync\ * and start Vivaldi once more to get rid of the crash.

    Looks like bug VB-38402 "Crash after trying to load empty sync data"
    I confirmed it.

    Thanks for finding that out. I am pretty new to Linux so aside from deleting the sync folders I had no other clue on how to troubleshoot this issue.



  • @sojiro84
    Hi, thanks for help but I never heard: "bookmark list in the new tab page"
    Can you please explain again or show me a screen shot?

    0_1521019313895_screen.jpg

    Thank you, mib
    EDIT: The problem is if I delete Topsites in my profile and copy/paste it from my old profile then manual refresh does not work. The sreenshot is with a fresh profile and manually added speed dials.
    Cost me 1-2 hours of work but this is beta testing. ๐Ÿ™‚



  • @mib2berlin ! in your screenshot you are almost where I need you to be. In my picture below, In the first red square, that is where your bookmark list is. Click there.

    In the third red square I selected "Game News" that I want to refresh the thumbnails for.

    In the second red square, I can tell Vivaldi to refresh that folder (that is also on my speed dial). That should bring thumbnails back.

    You can select multiple folders. If there are folders in your folder then you need to expand the folder first and select the sub folders manually. Vivaldi doesn't automatically fetch thumbnails for the folders in folders.

    0_1521028427282_Naamloos.png


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.