GPU Process 600mb cold launch



  • I'm confused as to why my GPU process is registering 600+ MB usage when no tabs are open and it's just the speed dial page visible? I have 10 speed dial pages 3 of them have compressed and downsized GIF thumbnails the rest are small JPG pictures, the background is fixed static wallpaper not animated and only 6 extensions running the highest RAM usage by one of them is 36MB so i doubt this is the work of a buggy extension. I noticed during YouTube playback my CPU gets super hot and my GPU processor goes from 10% or less to 100% as long as the video plays, I tried various quality options even at 144p didn't make a difference, this is not really ideal, i've tried all I can to embrace Vivaldi but these things make it so hard to keep it because i'm worried about stressing my hardware now.


  • Moderator

    @nickparkermusic Sounds as though there may be a conflict between your GPU and Chromium-based (except possibly Chrome, which may blacklist and therefore exclude the GPU) browsers. Do you know how to turn off hardware acceleration in Vivaldi?


  • Moderator

    On macOS, some videos types (e.g. H.264 / MPEG-4 AVC) are decoded via the GPU process so disabling hardware acceleration will render those types of media unplayable in Vivaldi.

    Are you using any extensions that override preferences which might be causing media players to select H.264-encoded videos and play them at their highest available resolution?



  • Thanks a lot for replying Ayespy and Xyzzy

    I should have provided more information in the original post but i wasn't sure anyone would reply so i wrote a briefing.

    Here's a list of my Chrome://Flags that I have enabled
    alt text

    And my Add-Ons:
    alt text


  • Moderator

    @nickparkermusic Perhaps you ought to try Vivaldi just "vanilla," and then add some of those flags and extensions a bit at a time so that you can see when the GPU begins to struggle.

    That's an enormous amount of complexity to try to guess which thing(s) you have done that that create the problem.


  • Moderator

    @nickparkermusic Agreed. Start off by resetting all of your Flags back to their defaults. The vivaldi://flags page contains a dire warning; do not ignore it. The only flag that I would even consider enabling is #ignore-gpu-blacklist. Nothing else.

    Remember that if Chromium disabled your GPU, it did so for a good reason; there was something about your graphics driver that caused performance or stability issues with the Compositor/Renderer. Don't try any graphics-related tweaks because that will most likely introduce even more instability.

    Remember that changing any flag from its default can potentially affect Vivaldi in very unpredictable ways.



  • Thanks a lot for your precious time and useful replies. I will use both suggestions and see if I get better results.

    I still gotta work out my mouse cursor playing hide and seek issue which is happening too often now it's frustrating because i'm not doing anything to trigger it, I know Full-Screen mode can be troublesome but I never go full screen mode.

    Have a nice weekend.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.