Scrolling Over Empty Tab Bar Area to Switch Tabs



  • Scrolling while the cursor is hovering the empty area of the tab bar should also change the current tab.

    Currently using the feature Switch Tabs by Scrolling in the tabs options requires the cursor to be over an existing tab. It'd be nice if always worked as long as the cursor was hovering the window header, like the empty part of the tab bar, or bonus, even the menus area above it.



  • @duarte-framos For info, at least on my current config, it already works this way on empty part of the tab bar. (Ubuntu 14.04 + use native window setting)



  • Related to this bug. It will work if your tabs are at the bottom



  • Indeed, using Native Window seems to make it work, wasn't aware of that bug.
    Not sure if this still stands as a valid feature request, feel free to delete/flag this post. Fixing that bug would be nice though.



  • still not fixed, only works if tab bar is bottom.



  • alt text

    When "switch tabs by scrolling" is enabled, please make it work when our mouse cursor is hovering anywhere across the entire tab bar section, including anywhere across the blank tab area and other button areas along the same row. Right now it only works when our mouse cursor is specifically hovering over tabs and the new tab button, which is very limiting.

    [bug reported VB-48376]



  • Curiously, it already works over the New Tab button and the Trash Bin, and also anywhere over the separator if you have Tab Thumbnails enabled.

    However, as pointed out before, this is a bug that does not affect native windows, or any other tab bar position.



  • As a quick workaround so far, you can hold the Alt key to access the tab switcher. In this case you needn't even hover the tab area, Alt+Mousewheel works everywhere in the current window.



  • @LWChris

    using the thumbnail view of the tab cycler is not really a workaround for this.



  • @LWChris Thanks Chris. That is a lot easier than using RMB scroll or Ctrl+Tab.

    It does not seem to be mentioned in help, so I added it to my list of Undocumented Shortcuts


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.