Videos do not play at Google News



  • Videos play correctly in Edge, IE, but not in Vivaldi, Chrome, or Opera
    I've just newly installed Windows 10 Pro Desktop machine with a brand new SSD, and I've found that (at least some) videos that properly run in Edge and Internet Explorer have sound, but no display in Vivaldi, Chrome, and Opera. This is happening on videos at news.google.com and elsewhere. Additionally, the video advertisements prior to the video I wish to see work properly while all I get of the video, itself, is audio and a black screen.

    [modedit] Changed title


  • Moderator

    @coover The videos on Google News seem to be on linked sites. Please provide a direct link to a video that does not play for you.


    Specs: AMD A10-6800K, 8 Gb on Win 10 64-bit • Snapshot 1.15.1111.3 (64-bit)



  • Right clicking on a blank video and copying the video url, I get http://people.com/ffaff4bf-49e8-4825-9f95-afaafdae4f65



  • @coover said in Videos play correctly in Edge, IE, but not in Vivaldi, Chrome, or Opera:

    Right clicking on a blank video and copying the video url, I get http://people.com/ffaff4bf-49e8-4825-9f95-afaafdae4f65

    That link gives a "Page Not Found" message!?



  • @coover

    I would bet it's the same thing I was facing.
    You maybe want to try the solution given from @zmeYpc in here:
    https://forum.vivaldi.net/topic/25526/embedded-youtube-videos-are-broken?page=1



  • @freeman79

    Strict site isolation is not enabled.

    I'm still having the problem and I have not been able to find a source site that would open.

    When I click on Copy Video Address, I get blob:http://video.foxnews.com/595b3627-e6c8-43fb-96ab-52ee666db66d

    When I click on Inspect, I get a src address = <video class="akamai-html5 akamai-media-element" data-isad="false" src="blob:http://video.foxnews.com/595b3627-e6c8-43fb-96ab-52ee666db66d"></video>

    Both addresses are the same. When I attempt to go to the website, I get a website not found error



  • Interestingly enough, I can get closed captioning, but not the video0_1520305949518_Capture.PNG



  • You can close down Vivaldi and delete the "WidevineCdm" folder in the "user data" folder. See vivaldi://about for the location. Then, start Vivaldi, goto vivaldi://components and update "Widevine Content Decryption Module" just to make sure you have the correct version.

    You can also try to find an extension like this one that lets you mask the user agent as Chrome to see if the site is discriminating against Vivaldi.

    I'm still having the problem and I have not been able to find a source site that would open.

    When you're on the page with the video, you can ctrl + shift + i to load the developer tools and go to the "Network" tab. Check "disable cache". Then, hit F5 to reload the page. Then, just click to play the video if it doesn't play automatically. Then, in the network tab, you can switch to the "Media" filter and look for an mp4 for example that's being downloaded. Then, you might be able to get a URL to the actual video. The URL might have a token in it that expires after a while though, so if you post the link, someone here will have to check it pretty fast. Also, sometimes videos are downloaded in parts. If so, there's probably something in the URL like a range that you have to get rid of to be able to load the video directly, which is what you want to do to see if it works. You also want to be able to download the whole video file using that modified URL if possible so you can drag the local file into Vivaldi to see if it plays fine locally. That can tell you a lot.

    Also, after you try to play a video, goto vivaldi://media-internals and expand the section for a player to see if it shows any errors. Also, vivaldi://gpu can tell you about hardware h.264 decoding support. You can goto vivaldi://settings and disable "Use hardware acceleration when available" under the "System" section and restart Vivaldi just to see if that makes a difference. That can tell you a lot too.



  • @burnout426

    Thanks burnout.

    I've tried what you suggested. I was able tgo find the WidevineCdm folder and deleted it and then updated it.

    I downloaded the extension you suggested and I tried it as Internet Explorer, Edge, Chrome, and Opera, but there was no improvement .... the ad videos played, and then a blank screen with the closed captioning appearing.

    I tried the developer tools as suggested. I have included a screen shot so you can see that the video did not even show a URL or file type.

    And the media-internals page showed no errors. There are no problems shown for h.264 decoding, and, unfortunately, the version of Vivaldi I have (1.14.10077.55) does not have a System tab in settings.
    0_1520385253921_developer.PNG



  • @coover
    In the command prompt, you can try with:
    vivaldi --disable-gpu

    Just to see if they play then.



  • @coover said in Videos do not play at Google News:

    unfortunately, the version of Vivaldi I have (1.14.10077.55) does not have a System

    Enter chrome://settings/system in the address field to get to it.



  • @coover said in Videos do not play at Google News:

    I have included a screen shot so you can see that the video did not even show a URL or file type.

    You might have to change the filter to "xhr" or "all" to find it. But, it indeed might not help on some of the sites that user blobs like you mentioned. If that's the case and you have the issue on a different site too, try testing on it instead to see if you can get an actual URL to a video.

    You can also try the widevinecdm folder from a Google Chrome profile in place of the one Vivaldi fetches from Google. It probably won't help though.

    You're sure you're using Windows 10 Pro though and not Windows 10 N, right? If you're using N, you'll need to download the Windows 10 media feature pack from Microsoft. If you do indeed have Pro or Home, then never mind on this part.



  • Thanks for the link to Chrome settings ... turning off hardware acceleration did it! It was and is the solution. Thanks, guys.

    And yes, indeed, Windows 10 Pro is running. I am my own IT and I installed it myself, having started with computers in 1961 (as a Math major in University), and now retired but volunteering in a Computer Laboratory for Senior Citizens. But I have little knowledge in some aspects of computing (such as this one). I am considered the Computer Guru in my neighborhood and town, but there is a lot more to learn and I do so everyday.



  • @coover said in Videos do not play at Google News:

    turning off hardware acceleration did it!

    That's cool that it worked. One shouldn't have to do that though. Just in case it's useful to some devs, what GPU and driver version are you using?


  • Moderator

    @burnout426 No, it "should not" be necessary. Unfortunately, Chromium is blacklisting more video cards with every release. Without the proprietary patches Chrome writes to get around this (and to which we are denied access), Vivaldi literally cannot keep up. We can only recommend that you take hardware out of the equation if Chromium does not support the card or its drivers.



  • @burnout42

    The Desktop machine is a Dell Optiplex 3020 which natively runs (on the motherboard) an Intel HD Graphics 4600. It's a nice computer, but something went wrong with the on board video card and the machine started blue screening. Determining that the culprit must be the on board video card, I looked for a cheap fix and found in a box an AMD Radeon HD 4350, a rather pedestrian card, but I'm not a gamer (unless you consider a Solitaire gaming), so it did the job. The driver is 8.970.100.9001, which, apparently, is the latest driver (sometime in 2015, I think). It's a nice machine, has an i5-4590 CPU, 8 GB RAM, and an SSD using Win 10 Pro 16299.251. I also own and operate 6 other machines in my home, all Win 10 and all running Vivaldi as default.



  • After trying to play a video (one that doesn't play) with Hardware acceleration on, do you see anything on the "Console" tab in the developer tools? Sometimes it'll show you an error/notice about something being blacklisted where it points to things like https://cs.chromium.org/chromium/src/gpu/config/software_rendering_list.json?l=673. Maybe something with show on vivaldi://gpu about disabled hardware acceleration.

    Maybe enabling vivaldi://flags/#ignore-gpu-blacklist might work.





  • 0_1521626788363_6751d03c-ce10-4d50-a7f0-526d8f8c031e-image.png
    This is how video on Facebook looks like on Vivaldi 1.14 and 1.15 (including the latest snapshot 1.15.1130.3).

    vivaldi://flags/#disable-accelerated-video-decode is not a real solution because whiteout the acceleration I experience low frame rate, also on YouTube.

    There are no problems whit 1.13 or previous versions.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.