How to limit Vivaldi to one instance only?



  • I sometimes unwittingly open a window instead of a tab which than creates such an amount of processes that my system begins to stall.

    Is there a way to limit vivaldi to one instance only?

    BTW, closing one vivaldi window often (not every time) results in closing all vivaldi windows.


  • Moderator

    You can't. It's by designed.



  • @michaa7 said in howto limit vivaldi to one instance only?:

    BTW, closing one vivaldi window often (not every time) results in closing all vivaldi windows.

    How do you close the window? because there is at least one way to close ALL windows at once, but ctrl-Q should close only current window.



  • @ian-coog said in howto limit vivaldi to one instance only?:
    ...

    How do you close the window? ...

    Using fluxbox as window manager I simply hit "close" in the pull-down menue of the tastk bar. This sometimes closes one window only, sometimes all windows.



  • @michaa7 well, you found the problem =)



  • @ian-coog Did I? How is that?



  • you can't blame vivaldi if the problem appear to be that fluxbox cause it. try closing the window in vivaldi and see if the problem persists.



  • As you're using fluxbox I'm assuming you know how to tinker under the hood.
    An old trick for a launcher is to use a wmctrl command to raise a window of a WM_CLASS or if there is no such window, start the application.
    wmctrl -xa <str> || <exec application>

    Start vivaldi.
    List windows showing WM_CLASS.
    wmctrl -xl

    Then use that info for a raise/start launcher.
    eg for vivaldi...
    wmctrl -xa Vivaldi-snapshot || vivaldi-snapshot
    or
    wmctrl -xa Vivaldi-stable || vivaldi-stable



  • @lamarca I wouldn't call it "design", it looks more like a restriction.

    My reference is old opera 12.16 (still running here). And when I try to run more than one Opera instance, I get a warning (because Opera notices that a second instance is trying to use the profile).
    This I'd call a feature.

    @ian-coog said in howto limit vivaldi to one instance only?:

    you can't blame vivaldi if the problem appear to be that fluxbox cause it. try closing the window in vivaldi and see if the problem persists.

    Untill now I only noticed this behaviour with vivaldi. I can have multiple VTs (multiple roxterm or multiple konsole) opened and close them one by one using fluxbox's pulldown menue. So it seems to me a bit <whatever> to claim it's a fluxbox flaw.

    @cantankrus said in howto limit vivaldi to one instance only?:

    As you're using fluxbox I'm assuming you know how to tinker under the hood.

    First time I have this issue. I don't have installed wmctrl, but from what I am reading there are now new fluxbox commands with the same or similar functionality. I'll give it a try, but I am not really conviced of this "solution".
    I still think (see above) its a restriction or a flaw within vivaldi.

    An old trick for a launcher is to use a wmctrl command to raise a window of a WM_CLASS

    What exactly does this mean. I explicitly do not want multiple vivaldi windows (with, maybe, an exception when I select "open window" in the context menue).

    ...

    Something you really could call a feature would be something like "move (tab/all tabs/whole session) to other session" (yeah, which one if more than two? Ok, then "combine all sessions").



  • @michaa7 said in howto limit vivaldi to one instance only?:

    @cantankrus said in howto limit vivaldi to one instance only?:

    As you're using fluxbox I'm assuming you know how to tinker under the hood.

    First time I have this issue. I don't have installed wmctrl, but from what I am reading there are now new fluxbox commands with the same or similar functionality. I'll give it a try, but I am not really conviced of this "solution".
    I still think (see above) its a restriction or a flaw within vivaldi.

    An old trick for a launcher is to use a wmctrl command to raise a window of a WM_CLASS

    What exactly does this mean. I explicitly do not want multiple vivaldi windows (with, maybe, an exception when I select "open window" in the context menue).

    Install wmctrl and test the appropriate command in terminal.
    If vivaldi is already running it will bring it into focus.(raise)
    Only when there is no vivaldi window will it start a new instance.



  • @michaa7
    This problem is probably not caused by the fluxbox as I don't use it and also get the problem with all windows closing when I only want to close one (and yes it is not all the time and not really reproduceable) there are even more cases of this problem here and here but you'll need to be able to understand german or french (sry)

    A solution so far is to switch on and off the spectre strict site isolation switch in the flags at vivaldi://flags/#enable-site-per-process
    I still need to figure out if switching this off and on (so reverse order) has the same effect.



  • @cantankrus said in howto limit vivaldi to one instance only?:
    ...

    If vivaldi is already running it will bring it into focus.(raise)
    Only when there is no vivaldi window will it start a new instance.

    Thank you for this explanation. You're completely right, I didn't get the proper meaning of "raise" in your first posting (not native english speaking person). Sounds like the desired command.



  • @zaibon said in howto limit vivaldi to one instance only?:

    @michaa7
    This problem is probably not caused by the fluxbox as I don't use it and also get the problem with all windows closing when I only want to close one (and yes it is not all the time and not really reproduceable) there are even more cases of this problem here and here but you'll need to be able to understand german or french (sry)

    Thanks for confirming the problem. Your description completly fits my experience. BTW, native german speaker here ;-)



  • @cantankrus said in howto limit vivaldi to one instance only?:

    ...
    Start vivaldi.
    List windows showing WM_CLASS.
    wmctrl -xl

    Then use that info for a raise/start launcher.
    ...
    wmctrl -xa Vivaldi-stable || vivaldi-stable

    So this is what I get:
    $ wmctrl -xl
    0x01e00003 3 roxterm.Roxterm neutower <user>@<host>: ~
    0x01400001 3 vivaldi-stable.Vivaldi-stable neutower howto limit vivaldi to one instance only? | Vivaldi Forum

    What here is what I should use as <str>

    And then I write it into the FB menue?



  • @michaa7
    I installed fluxbox and testing here it seems the menu will do shell interpretation so you can
    just use what I showed in my first post as the fluxbox command.

    @cantankrus said in How to limit Vivaldi to one instance only?:
    Then use that info for a raise/start launcher.
    eg for vivaldi...
    wmctrl -xa Vivaldi-snapshot || vivaldi-snapshot
    or
    wmctrl -xa Vivaldi-stable || vivaldi-stable

    So for snapshot your fluxbox menu entry would be...
    [exec] (Vivaldi (snapshot\)) {wmctrl -xa Vivaldi-snapshot || vivaldi-snapshot} </opt/vivaldi-snapshot/product_logo_32.xpm>

    For stable...
    [exec] (Vivaldi) {wmctrl -xa Vivaldi-stable || vivaldi-stable} </opt/vivaldi/product_logo_32.xpm>



  • Thanks.

    It works and is exactly what I was looking for. Opening Vivaldi in whichever workspace will raise (show) an already opened vivaldi window. So one wouldn't open a second instance by accident.

    On the other hand, if really needed, you still can open a secondary vivaldi window using the vivaldi menue.

    Thanks again.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.