Address Bar and Toolbars Missing

  • I'm sure I'm missing something simply here, but when I open Vivaldi all I get is a fullscreen window with the page title on it - no address bar, no toolbar, no icons in the bottom left

    It's not the same screen I get when I hit F11.


  • Moderator

    @robfuscate You appear to be stuck in app mode, which does not work in Vivaldi. The only way I know to correct that is to refresh your profile.

  • Look for the Preferences file and edit it with a text editor. There is an entry address_bar and a property visible. Set it to true instead of false. I'm not sure why it happens, aber I had the problem, too and this solved it. If tabs are also missing, search for tabs with visible attribute.

    On Ubuntu you'll find the Preference file here: ~/.local/vivaldi/Default/Preferences

  • /Ambassador/

    @robfuscate It looks like Chromeless Mode to me (Try Ctrl+F11).

  • My problem is the same, but this is even synchronized between my devices!
    The only is to reinstall and synchronize without settings...
    Please at least do not synchronize it

    UPDATE 21.01.19 the problem is gone. Don't know the reason, but thanks))

  • This post is deleted!

  • Hi,

    This issue is caused by a user entering full-screen mode.



  • Hi,

    It can be rectified by hitting F11 again.



  • @Hotwheelz This happened with me, when I closed Vivaldi in full screen mode. Only going into settings and ticking the missing UI elements brought back my... missing UI elements: Tabs, Adress Bar, Bookmark Bar.

  • @hneubauer THIS was a real solution. I also had the serious version of this issue - NOT full screen, NOT chrome-less ctrl+F11, etc. - the apparently impossible-to-fix version. @gyuuula may have the same solution but through the UI,

    In my case, Windows 7: ...AppData\Local\Vivaldi\User Data\Default, and there's a Preferences file. Drag it into an empty Notepad.

    Looking for "visible" after "address_bar" and changing it to "true" worked (FYI, I also changed "enabled": false to true, though I don't know if that was actually needed.)

    HOWEVER, I still had tabs missing. So in similar fashion, search for "tabs" (or, if everyone's is like mine, just scroll all the way to the bottom since it's in the last few lines), and again, change "visible": false to true.

    @Vivaldi staff. @Ayespy, etc., you guys should know now, I hope, that this is an editable file / changeable in settings and thus something worth checking, since "refreshing a profile" is hardly a "solution." That's a nice way to say "un-fixable, undo everything you've done involving the whole reason why you've chosen this browser and hope you can set everything up as before and remember all your tiny settings that are desired or needed and that you can slowly figure out what was wrong. Don't know if these are new implementations but nice to see there's a way out, though this is the only resource I could find saying so.

    Granted, this still doesn't fix the cause of the issue, and that's something for us to do, following the steps of refreshing a profile / creating a new profile, but at least we can get back to any critical work.

    A browser should adapt to you, not the other way around.
    We believe that many people want to customize and tweak every square inch of their browser to make it their own.

    So don't ask us to undo what may have taken an uncountable amount of time 😲 when the browser should be built with these values editable through the file or settings.

    I think many designers, in the path to create powerful, customize-able, awesome software like Vivaldi, forget or face real technical difficultly in also making it easily, modular-ly reset-able, to make sure users always have the option to turn on or keep on the critical features. Even though it seems now that there's a way for us to fix it... I don't know, doesn't matter what a crazy Chrome extension might do; is it hard to have a line of code that says IF #Windows = 1, ForceNormalWindow OR convert PopUp to Normal? A force UI reset button?

    Powerful software needs powerful defense! 🙂

  • @gyuuula So you even had "show tab bar" off? I was PRETTY sure I checked all the settings but maybe I missed that one. If all the options are there, editing the Preferences file may not be necessary. I'll pay attention if it happens again.

    Basically, I'll corroborate that it was definitely possible to turn on most things through settings.

  • Got stuck without address bar too after a spell in full screen video. Just go to settings > address bar > show address bar to fix it.

  • This post is deleted!

  • Hello,

    I had the same issue today.

    Caused by: Video-Fullscreen (youtube) and the stupid idea to leave it with F11 (fullscreen) hotkey.
    The preferences looked fine and the other suggestions in this thread doesn't helped too.

    Was already prepared to reset my whole profile, but then remembered one feature I almost forgot:

    Open PanelClick on Session Icon (red)Click on New Session Button (blue):

    With that, I was able to:

    1. Create a new window with a working address-bar
    2. To save my session (select everything and save all) from the corrupted session
    3. And load it into the new working session (from step 1)

    So if the preferences looking fine when this bug occurs, we should also look the next time
    into all session-related files and check out, if there is some toggle open which disables
    the address-bar or enterin the app-mode.

  • @novek Thank you, Novek! It went missing on both my PCs after upgrading to v. 3, but your method worked.

  • @Pesala said in Address Bar and Toolbars Missing:

    @robfuscate It looks like Chromeless Mode to me (Try Ctrl+F11).

    Thank You! It was a horror 😃

  • @novek Thank you!! It worked.

  • @Pesala thanks dude you save me.. ❤

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.