Bug: "forward" and "back" keys ignored on Linux

  • I have a Logitech MX-518 mouse that has two thumb buttons which I mapped to "forward" and "back" (sorry I don't have more specific designations, it seems to be the same as the "multimedia keys" on some keyboards"). Those keys work perfectly in any other browser, Opera 12 for example, but Vivaldi (all versions I tested) ignores them. (kubuntu 14.4 is in use) NB: I have the same mouse at work under Windows, Vivaldi correctly listens to the forward/back keys there. So Linux only.

  • Confirmed with my Logitech M560 mouse.

    The „Tilt scroll function“ (back/forward when tilt left/right the scroll wheel) don't work in Vivaldi under Linux.
    No problem with Chromium, Opera and Firefox (Iceweasel).

    OS: aptosid x86_64 with Xfce

  • Confirmed. Other browsers work fine with this keys.

  • I've been complaining about this issue since day 1 …

  • Yep - same here with logitech performance mx mouse

    Other browsers are working OK

  • Same here. Logitech MX510 mouse. Back and Forward keys does not work under Linux in Vivaldi. When they get it working I'll make an immediate switch from Chrome and Vivaldi will be my default browser. I like it.

  • Same here, not only Logitech mice. Should be taken care of, as it is an important feature.

  • Could this be somehow related to this bug that I've written about earlier? Can you guys please check if the Backspace key works for you as the back shortcut?

  • Backspace doesn't work either. Not sure if this is related.

  • Backspace doesn't work. I've got a Genius Comfy-KB09e keyboard with dedicated Back and Forward buttons, these buttons are working fine.

  • Pretty important feature here. This is the only deal breaker I have ATM.

  • Yeah, this is a serious issue. It could be possible to set Backspace as a shortcut key in options, but pressing Backspace just clears the field.

  • btnx is a good temporary solution till it's not get solved by Vivaldi browser. I've installed it, configured only the Back and Forward mouse buttons and happily said good-by to Chrome.

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.