Problems with some extensions (Evernote, Pocket)



  • I use Vivaldi 1.15 (most current snapshot) with the extensions for Evernote and Pocket from Google Webstore. The same extensions work without any problem with Google, but in Vivaldi I can not enter any strings into the dialogs/popups of this extensions. The snapshot of web-pages itself works, but I can not enter tags or labels before saving the snapped page.
    The same thing works without any problem on Chrome. I think, also with older Vivaldi (1.13 or so) the extensions work ok, but with vesion 1.14 and 1.15 the problem occurs.
    Are there any specific differences between Chrome and Vivaldi in this area?


  • Moderator

    @afischer211 Such issues are usually due to poor browser detection by a web site.



  • FWIW, since the 1.14 Stable series, some of my extensions are behaving peculiarly. User-agent-switching extensions don't work at all to actually change the user agent, though the extensions themselves indicate they have changed the UA (both for UserAgentSwitcher and URL Sniffer). ScriptSafe behaves oddly sometimes when trying to disable it from its extension-bar icon (it cuts off all the text below its 1st line of extension options for sites having many scripts, blocking ability to disable it from the icon while on that page). Click&Clean no longer allows any selection of options from its panel when selected from the extension bar icon. These problems existed some months ago, but were cleared up and things fully worked in 1.13 Stable; the problems returned after the 1.14 series of updates.



  • @blackbird This sounds like my problems with the extensions for Evenote and Pocket. But what can I do for resolving the problem?



  • @afischer211 said in Problems with some extensions (Evernote, Pocket):

    @blackbird T... But what can I do for resolving the problem?

    I think what a given user has to do depends on their browsing configuration "needs" and tolerance levels. In my case, I can live with the issues until a future Stable update fixes them... for sites that require a non-Vivaldi user-agent-string, I use a different browser; when ScriptSafe cuts off the text and blocks disabling it when I need to, I click on my HTML homepage, disable SS, and jump back to the sought page; with Click&Clean, I don't tweak the options that often, so I simply live without them for now. In a worst case, one could always install Vivaldi's 1.13 version, either replacing the current v1.14 or beside it as a stand-alone version... though that risks exposure to emerging Spectre/Meltdown exploits. Alternatively, one could try Developmental versions in hopes that the fixes arrive there soon (and they will arrive there before they arrive at the Stable channel).



  • I came here today looking for a solution to my Pocket problem. I have the same problem as the OP - the pages save but I can't enter strings into its dialog boxes. I am pretty sure that I was previously able to do so in Vivaldi. I have gone through and disabled other addons with no change.

    Today I discovered a new issue: if I try to login to the Pocket website in Vivaldi (getpocket dot com), the tab crashes, every time. All other tabs stay open. I am able to log in to my pocket account via the extension; this is an issue with the website.

    Does this happen to anyone else? Could it be connected to the extension problem or is it a separate thing?

    Windows 10, Vivaldi 1.14.1077.55 (Stable channel) (64-bit)



  • Update: the second problem, of the login tab crashing, seems to have gone away in v.1.14.1077.60.

    The original problem remains. The dialog boxes generated by the extension remain unusable so I can't add tags etc.

    When I go to the Pocket site, now that I can do so without it crashing, I don't have the same problem. I can pull up my saves and add tags via the dialog boxes that pop up there. So that is my workaround for that particular function. I am still hoping the issue will be resolved in the near future.



  • Similar issue here with Evernote Web Clipper extension: had it working fine in Vivaldi until recently (dunno exactly, but somewhere between 1.14 & 1.5). I'm currently running Vivaldi 1.15.1132.3 and once the extension dialog has been displayed, nothing can be done: buttons can't be clicked, clip type can't be changed, and unable to key in a tag in the appropriate field.
    Just check with latest Chrome (65.0.3325.181), but the extension works fine, so something changed in Vivaldi that puzzles the extension. I'll file a bug for Vivaldi, but will also notify Evernote, as the problem may also be theirs.

    #evernote-web-clipper


  • Moderator

    I am having problem to save logins with LastPass, reported already.



  • I can confirm Evernote Clipper is not clickable. Lastpass also not clickable. They show up but like covered by invisible layer. Like div absolute, z-index: 999999 ;)



  • @amdad I have same problem, looks like the developers never use evernote....



  • @TerDale This cannot be from Evernote since the issue is the same with OneNote, Pocket, LastPass (and probably other extensions). It has become totally impossible to save a page since the last two snapshots (or last three)



  • Fixed in Vivaldi snapshot 1.15.1146.5

    #evernote-web-clipper



  • @terdale said in Problems with some extensions (Evernote, Pocket):

    Fixed in Vivaldi snapshot 1.15.1146.5

    Not fixed yet, at least for Kee and ChromeIPass.



  • @stilgarwolf OK, disappointing news. Actually, I inferred the fix ("[Regression] Some extensions don’t react on mouse click (VB-38617") was fitting all...
    Anyway, I purposely replied my own post to announce the fix, as I'm able to confirm it's fixed for Evernote Web Clipper extension, but can't tell for other extensions displaying page overlays, except for "Just Read" that is also properly working again.

    #evernote-web-clipper #just-read



  • @terdale I am sad to report that the Pocket tag issue is still there. :-(
    I ran into a couple of websites that wouldn't accept keyboard input in form fields (so no typing or Ctrl-V) but would accept mouse input (right click, Paste). I was hoping that would work for Pocket tags but no. The extension's dialog boxes are invisible to the browser. :-(



  • Ugh I now cannot click in any recaptcha form on any page in Vivaldi. Since those infernal things are everywhere now, this is a huge problem :-(
    Version 1.15.1147.21 (Official Build) (64-bit)


  • Moderator

    @phoenix-fox Problems with reCaptcha is not a extension issue!


    Some users have a problem. Please see https://forum.vivaldi.net/post/203817
    The issue comes up if you Enabled Strict Site isolation on internal page vivaldi://flags



  • This seems to have gotten mostly worse since the last patch.
    I used to be able to click on things in extension popups, but not enter text. I now can't even click on anything in Evernote, Pocket, Harvest etc...

    uBlock Origin's advanced settings seem to be clickable again though, and avast Online Security also seems to have become clickable.
    Some extensions (few) such as FreezeTab have always worked ok.

    Not sure what's the difference between them, but given how common Evernote and Pocket are.. :-(

    EDIT: Ok, it's the Strict Site Isolation flag that does it.
    Right after posting this I also had the captcha issue, so I tried restarting Vivaldi without strict site isolation and suddenly Evernote, Harvest and Pocket all work fine (clicks and text boxes).
    I assume they're loading external sites in the popup window, whereas the one that work have everything installed locally?

    Given that Google recommended turning it on, and that it'll be the default in Chrome soon (i think), I wonder if these extensions currently work in Chrome, and if not, if the writers will have to re-write them.

    Either way, it's something the Vivaldi team should keep an eye on at least, so they don't end up with most extensions unusable.



  • @gwen-dragon said in Problems with some extensions (Evernote, Pocket):

    @phoenix-fox Problems with reCaptcha is not a extension issue!


    Some users have a problem. Please see https://forum.vivaldi.net/post/203817
    The issue comes up if you Enabled Strict Site isolation on internal page vivaldi://flags

    Thank you! That fixes the problem with Pocket as well!

    I enabled strict site isolation in the early days of Spectre and Meltdown. I forgot about that.

    I am very relieved. So happy to have Vivaldi back as my primary browser.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.