Vivaldi not restoring browser tabs



  • I've got my settings for "Startup with" set to "Last Session". However, if I close Vivaldi (latest stable version) and re-open I get the start page and lose all my tabs. This is happening on two different linux distros - OpenSUSE and LinuxMint. On my Mint box I actually blew out the entire profile directory and that seemed to fix the problem but now its occurring again. Any suggestions?

    1.14.1077.41 (Stable channel) (64-bit)


  • Moderator

    @mr_clark This happens if not all Vivaldi processes close before restart.



  • Thanks. I was actually thinking about that after I submitted this post. I closed Vivaldi and did a 'ps' and discovered a bunch of vivaldi-bin processes running. Killed them and started again and my old tabs all opened.

    Guess I'll have to keep an eye on that.

    Thanks.


  • Moderator

    On your profile folder (see vivaldi://about) check for the following files:

    • Last Session
    • Last Tabs
    • Current Session
    • Current Tabs


  • @mr_clark said in Vivaldi not restoring browser tabs:

    discovered a bunch of vivaldi-bin processes running

    To obviate that, you might want to check that your "pink boxed" setting is off, like this:

    0_1518821942496_20180217_002.png


  • Moderator

    @mr_clark said in Vivaldi not restoring browser tabs:

    Thanks. I was actually thinking about that after I submitted this post. I closed Vivaldi and did a 'ps' and discovered a bunch of vivaldi-bin processes running. Killed them and started again and my old tabs all opened.

    Guess I'll have to keep an eye on that.

    Thanks.

    If none of the instances were zombies (defunct), then the
    tip above ( chrome://settings/system) will prevent the Vivaldi delay on closing all the "bins".


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.