Option to Remove the Navigation Bar from Start Page



  • I have no folders, and don't often use the Bookmarks or History Tabs. It is more important to maximise the space for speed dial thumbnails.

    I currently use some CSS to remove the navigation bar, but I have to reapply this with every update.

    .startpage-navigation {
    display: none !important;}

    By hiding the Speed Dial Titles too, I could fit 4 columns and 6 rows of thumbnails on my 1200 x 1600 pixels monitor @ 110% UI Zoom.



  • I have a folder now on my start page, but not one that needs the navigation bar to access it.

    0_1538501898984_Start Page Folder.png

    I use some more CSS to make the folder icon transparent and use a custom thumbnail.

    .startpage .dial .thumbnail-image {
      background-color: transparent;
    }
    .speeddial .dial-columns .folder .thumbnail .thumbnail-image {
        box-shadow: none !important;
        border-width: 0;
        transition: all 0s ease 0s;
    }
    .speeddial .dial-columns .folder .thumbnail>.thumbnail-image {
        background: none !important;
    }
    .speeddial .dial-columns .folder .thumbnail .folder-flap {
        display: none;
    }
    .thumbnail-image {box-shadow: none !important;}
    .startpage-navigation {
    display: none !important;}
    .bookmark-bar button[title="Show folder contents"] svg {
        display: none;
    }
    .bookmark-bar button[title="Show folder contents"] span {
        margin-left: unset;
    }
    


  • Please add an option to hide the start page top bar that contains "bookmarks" and "history". Because I don't use any of the start page functions so I want my start page to just act as a dark blank page for new tabs.

    [bug reported VB-47974]



  • Courtesy of @pafflick I now have the navigation on autohide until I hover the mouse cursor over it. I adjusted the timing to just 0.1 seconds.

    /*Show Start Page Navigation Bar on Hover*/
    @keyframes hide-startpage-navigation {
    	from {
    		top: 0;
      }
    	to {
    		top: -45px;
        opacity: 0;
      }
    }
    .startpage-navigation {
    	animation: hide-startpage-navigation 1s ease forwards;
    	animation-delay: 0.1s;
    }
    .startpage-navigation:hover {
    	animation: show-startpage-navigation 0.1s ease forwards;
    }
    
    


  • @Pesala Try this, it's much better solution: https://forum.vivaldi.net/post/264165


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.