Amazon Prime video: Vivaldi incompatible...



  • Has anyone found a workaround to get Amazon Prime videos to work. It is OK in FF, Opera and Chrome but just hangs with Vivaldi. Looking at the Help it is very specific which browsers work. Vivaldi isn't on the list.


  • Moderator

    @rafiki I read somewhere that you keep Developer Tools window open and change the user agent to Firefox or Chrome.



  • I've had no trouble running amazon video with the latest snapshot. If you go to vivaldi://components can you make sure that the widevine content decryption module is installed properly?



  • @pesala said in Amazon Prime video: Vivaldi incompatible...:

    @rafiki I read somewhere that you keep Developer Tools window open and change the user agent to Firefox or Chrome.

    Thank you. I looked in Developer tools but I didn't see any way to switch. I guess it's there but I'm not familiar with the setup and am wary of messing something up.



  • @lonm said in Amazon Prime video: Vivaldi incompatible...:

    I've had no trouble running amazon video with the latest snapshot. If you go to vivaldi://components can you make sure that the widevine content decryption module is installed properly?

    Thanks. Widevine is in the list and it says it is up to date.



  • @lonm said in Amazon Prime video: Vivaldi incompatible...:

    I've had no trouble running amazon video with the latest snapshot. If you go to vivaldi://components can you make sure that the widevine content decryption module is installed properly?

    I've been away so just updated to the latest snapshot but still no joy with Amazon Prime videos unfortunately. Still works OK on Firefox.


  • Moderator

    I have no Prime, but using a extension like User-Agent Switcher (UASwitcher) and adding Chrome 64 as useragent does not help?
    Try this user agent to add in settings of UASwitcher
    Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.143 Safari/537.36



  • I run amazon in a separate profile (to prevent tracking). This means I run it with pretty much vanilla settings and there's nothing to interfere with it. You could try this.

    1. Press Win+R
    2. Type the following: vivaldi.exe --user-data-dir=amazon
    3. Try to use amazon as normal, but don't touch any settings and dont do your normal browsing or extensions here


  • @gwen-dragon said in Amazon Prime video: Vivaldi incompatible...:

    I have no Prime, but using a extension like User-Agent Switcher (UASwitcher) and adding Chrome 64 as useragent does not help?
    Try this user agent to add in settings of UASwitcher
    Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.143 Safari/537.36

    Thanks. I installed UA Switcher. Prime wouldn't run with either the default Chrome nor with the string you provided unfortunately. I also tried with my adblocker disabled but it made no difference.



  • @lonm said in Amazon Prime video: Vivaldi incompatible...:

    I run amazon in a separate profile (to prevent tracking). This means I run it with pretty much vanilla settings and there's nothing to interfere with it. You could try this.

    1. Press Win+R
    2. Type the following: vivaldi.exe --user-data-dir=amazon
    3. Try to use amazon as normal, but don't touch any settings and dont do your normal browsing or extensions here

    Thank you. I ran it that way but it still wouldn't run. The player just times out.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.