Toggle Image does not persist between tabs?



  • I routinely tether my laptop to my phone while commuting (1-hour each way...), and I just started using Vivaldi. I really like the "Toggle image" feature (especially setting it to "From Cache", so the web isn't a complete void). However, I just noticed that this setting does not persist between opening tabs. That is to say, if I open a new tab with Ctrl+T, or middle click a link to open a new tab, the "Toggle Image" setting resets to "Always" in the newly opened tab.

    Is this an intended behaviour (and if so, can I change it?). If it's not intended, is this a bug? How should I report a bug through the official channel if this is indeed a bug?

    For what it's worth, here's my Vivaldi About page:

    Vivaldi		1.15.1090.3 (Official Build) (32-bit)
    Revision	c8346f3cb5895ae369a5deae4eaeb7a90690c81d-
    OS		Windows
    JavaScript	V8 6.4.388.40
    Flash		(Disabled)
    User Agent	Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.121 Safari/537.36 Vivaldi/1.96.1090.3
    Command Line	"C:\Users\usr\Utilities\Vivaldi\Application\vivaldi.exe" --vivaldi-standalone --always-authorize-plugins --flag-switches-begin --flag-switches-end --disable-smooth-scrolling https://vivaldi.com/newfeatures?hl=en-us&version=1.15.1090.3&os=W10.0.16299
    Executable Path	C:\Users\usr\Utilities\Vivaldi\Application\vivaldi.exe
    Profile Path	C:\Users\usr\Utilities\Vivaldi\User Data\Default
    Compiler	clang
    

  • Moderator

    That works only on the tab where you made the Toggle.

    Known and already reported issue in internal bugtracker.
    VB-10729 "Global settings for image toggling"



  • @Gwen-Dragon So it is acknowledged to be a bug?
    I personally like the fact it is tab specific! ^^
    I don't know if it is possible to add info to the ticket you're speaking about, but if so, I would like to add that some user may prefer this behavior to be at least optional, instead of completely changing it ;)


  • Moderator

    If someone needs an other setting (tab or global) they could add a feature request at Feature Requests.



  • Sorry, I'm not sure to understand you well: You mean the current behavior is a bug (cf VB-10729), and once corrected if we want it back you recommend to add a feature request?
    Seems a bit cumbersome... But ok I understand your point if it is currently really counter-intuitive for most people.


  • Moderator

    @guilimote It means it is a bug. If you want an option to make the setting per tab, and not global you should make a feature request as the current buggy behaviour will be fixed.


  • Moderator

    @guilimote OK, my fault to post such confusing things.
    I meant:
    It is a Bug when the setting in statusbar is lost for other tabs.
    It is a missing Feature if one can not set globally the display of images in Vivaldi Settings page.



  • Ok, thanks.

    @gwen-dragon said in Toggle Image does not persist between tabs?:

    It is a Bug when the setting in statusbar is lost for other tabs.

    Is it really designed this way? For example, the "zoom" setting is also located in the status bar, but is specific to current tab. Is it also considered as a bug? (true question). It seemed relevant to me that all the actions in the status bar apply to the same space.


  • Moderator

    @guilimote Sorry, i do not know if it was was designed to be only working for one tab.

    I am not a 100% fault-free support gal. And i am not The Doctor having a solution with its electronic screwdriver for all issues of the Vivaldi universe. scnr.



  • @gwen-dragon Hahaha, no problem!

    But still, you are kind of a witch knowing the truth behinds the wall of the private bug tracker ;)
    And as we, mere mortals, don't have access to this tracker, it is sometimes difficult to differentiate what you are saying based on your "free volunteer" assumptiom from what you can read or know comming directly from Vivaldi team.


  • Moderator

    @guilimote Feel free to ask me if my posts are unclear.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.