Redirect to custom search's homepage when searching with nickname+empty field



  • In Opera, if you search using a nickname and add only space afterwards (i.e. no search term) you get redirected to that custom search's homepage.

    For example, let's say I have set a custom search for "Youtube" with a nickname "yt".

    Now, when I want to search Youtube, I type something like this:
    yt funny cats

    Which will correctly redirect me to Youtube's search page with the terms "funny" and "cats".

    But if I type:
    yt<space>

    That is, nickname and space, Vivaldi will try to load:
    http://yt/

    Which is a website that does not exist, obviously. In Opera, it would redirect the user to "youtube.com"

    Is it possible to add a feature to redirect to the custom search's homepage when searching by nickname with an empty search term.



  • @thefoxbard doesn't it redirect properly if you just type 'yt' and no space? I thought that's what it did for me (I don't have a pic to check this right now).

    If not you could always bookmark this page and set 'yt' as a bookmark nickname. Though be aware that would break auto losing nicknamed bookmarks by quick commands


  • Moderator

    Create a bookmark to www.youtube.com with the nickname that you want.



  • @lonm said in Redirect to custom search's homepage when searching with nickname+empty field:

    @thefoxbard doesn't it redirect properly if you just type 'yt' and no space? I thought that's what it did for me (I don't have a pic to check this right now).

    If not you could always bookmark this page and set 'yt' as a bookmark nickname. Though be aware that would break auto losing nicknamed bookmarks by quick commands

    Without space it searches in DuckDuckGo(default search engine) for "yt".

    Setting the bookmark nickname as "yt" did the trick, though, so thank you very much @LonM and @Pesala :)

    But still, it would be nice to redirect to the homepage when no search terms are provided, as it would prevent Vivaldi trying to connect to a weird nonexistent webpage.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.