[Solved] Really huge notifications since some 1.14 snapshot



  • With one of the recent 1.14 snapshots (don't know which one, unfortunately), Vivaldi suddenly started to display browser notifications in a different way. Before, they would use the browser theme style and just create small mini windows popping up in the lower right corner. But now, they've started showing up as giant boxes, obviously using window manager mechanisms.
    It might be specific to Awesome WM, which I use (on Arch Linux). However, Awesome hasn't been updated in a long while, so definitely nothing changed there.
    What actually makes the notification so big is the icon, while the text displays as usual. The window covers about 1/8 or so of a full HD screen, which makes it really annoying (e.g. using Slack for work and having notifications constantly hiding the things you're actually looking at).

    However … everything is normal again when creating a new browser profile, that is, after removing ~/.config/vivaldi-snapshot/. So there must be something in my profile that is broken or set to the wrong value. However, I was unable to find anything.

    So here's the actual question: Does anybody know a setting/file/whatever that could be related to the problem, and which is easy to fix? I'd like to avoid to create a new profile from scratch (and export and re-import stuff, setting things up, etc.) if possible, especially since if it has happened once, why should it not happen again next week…

    Thanks for your time!



  • @elkmonster It does not happen to my V-SS; the popup notifications remain acceptably subtle IMO.

    Does anybody know a setting/file/whatever that could be related to the problem, and which is easy to fix?

    No i don't "know", but i'm going to take an educated guess here. Based on a recent [re]discovery of mine, posted elsewhere in the forum, it might be worthwhile you trying this. Delete or rename your equivalent of: /home/steffie/.config/vivaldi-snapshot/Default/Local App Settings/mpognobbkildjkofajifpdfhcoklimli

    Otherwise...

    create a new profile from scratch (and export and re-import stuff, setting things up, etc.)

    I fully share your desire to avoid this if possible. Having done it numerous times over the past three years, the novelty well & truly wore off yonks ago, & nowadays it's just a PITA [mind you, i've not needed to do it for ages]. However, unless someone else is able to specifically help you [& my suggestion above fails], then i fear you won't be able to avoid this drudge.



  • @steffie Thanks for your idea. Unfortunately, deleting Local App Settings didn't help.




  • Moderator

    @ElkMonster I was having the same issue with Desktop Notification. Disable the flags below worked for me.

    vivaldi://flags/#enable-native-notifications
    vivaldi://flags/#enable-message-center-new-style-notification



  • @lamarca Thanks, that worked! Hurrah! 🙂
    In fact, disabling vivaldi://flags/#enable-native-notifications was already enough.


  • Moderator

    @elkmonster Glad it works. I will flag your topic as resolved.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.