1.14 massive problems



  • This build is quite unworkable. Much of the time the mouse cursor is not accurate or does not actually click links. Google searches are not clickable at all. Some of the extensions are broken, including the Fair ad blocker. I'm getting a lot of partially unresponsive pages, on some of them it's impossible to scroll with any accuracy, if at all. I often get the pointing hand mouse link pointer, when I should be getting either a arrow or a I beam.

    I'm sure these problems will be resolved soon, but thought they were worth mentioning.



  • @paul1149 Yep, unable to click interactive elements is annoying. It happens when you open a new tab from a link (for some it happens from panel too). It's known and I hope they fix it soon, because it's very annoying. For the time being you can work around it by opening the address in a new tab (shift-enter/ctrl-enter [depending on your shortcut settings] while being in the address bar).





  • I usually use SS on a daily basis, but having read this thread i was intrigued & launched my 1.14 Stable to assess. Whilst i do have other reasons for being frustrated with this version, in fairness i must say that NONE of the problems mentioned in the above posts is afflicting my 1.14 in my Manjaro. How might we explain this dichotomy? I think it even further enhances my respect for the degrees of difficulty faced by the Devs, in trying to cope with divergent user experiences, sometimes being polar opposites.





  • [PROBLEM]
    https://web.whatsapp.com is crashing with dead bird black page.
    Many different sites also crashing.
    uBlock extension is not working.
    Deleting all cache files and folders is not helping.

    Go back to 1.13 and everything fine.

    [SOLVED]
    It was buggy libffmpeg.so from ubuntu.
    Got libffmpeg.so from https://repo.herecura.eu/herecura/x86_64/vivaldi-ffmpeg-codecs-64.0.3282.119-1-x86_64.pkg.tar.xz
    and everything fine.

    Linux Debian 9.3 x64, KDE



  • These are my specs in case it help the devs trobleshoot:

    System Spec 1: Vivaldi 1.15.1089.3 x64 - Windows 10 Pro x64 1709.1699.214 - MSI 970_AMD FX6300_16GB RAM_256GB SSD_3TB HDD_AMD Radeon R7-360 18.1.2

    System Spec 2: Vivaldi 1.14 x64 - Windows 10 Pro x64 1709.1699.214 - HP LT 17z_AMD A12 9720P_8GB RAM_1TB HDD_AMD Radeon R7-360 17.7.1


  • Moderator

    Vivaldi 1.14 on Linux?
    You can really sing loud: "He's a Rameater."
    After 1 hr my Debian 9 sang: "Its all over now, baby blue."
    4 GB should be enuff, but not if watching live streams.
    Desktop frozen. Had be root and use kill on other tty console. Not nice.

    Working now on my Win 10 PC :(



  • @petol777 said in 1.14 massive problems:

    https://web.whatsapp.com is crashing with dead bird black page.
    Many different sites also crashing.
    uBlock extension is not working.
    Deleting all cache files and folders is not helping.

    Go back to 1.13 and everything fine.

    Linux Debian 9.3 x64, KDE

    I didn't have any of those problems, that I saw anyway. But the others were enough for me to revert to 1.13 for now. I'm also on a Debian 9.3 base.



  • I have issues with this build as well. Performance is degraded.

    • Pages don't load properly. (I use uMatrix, but the components are not all shown in the matrix).
    • When I search on DuckDuck go and hit the back key, the page remains white frequently.
    • Memory usage is increased.


  • I have not been able to run any 1.14 or 1.15 Vivaldis. They open to a gray screen with V logo in the center, no X to close window, no menus, no response to quick commands; with my old profile or with a new one. The error message is:

    [10797:10849:0201/082534.460020:ERROR:bus.cc(394)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
    [10797:10797:0201/082534.734602:ERROR:gpu_process_transport_factory.cc(1009)] Lost UI shared context.

    I use Fatdog Linux, not a mainstream distro, and furthermore it's minimalist (the iso is half the size of Knoppix micro). I am not asking for personalized troubleshooting; I only report this in case the information is useful, since I assume the goal is for V. eventually to be as universal as possible.

    Currently using V 1.13.1008.44, which runs with a few minor glitches.
    Google-chrome (2/5/2018, chrome 64) runs (@ Steffie: for emergency use only!)
    Opera 50.0.2762.67 (chrome 64) runs
    Chromium (from Slackware)-- too lazy to chase down missing libs.

    64-bit Puppy Linux variants also do not work.
    Xenialpup64: same error
    Slacko64: wrong NSS version


  • Vivaldi Team

    @t160915 could you run vivaldi-stable --enable-logging=stderr and share the output?



  • I've switched to the Snapshot, 1.15.1094, and so far have not had any problems. I copied my profile over to it and will copy it back should I return to the stable channel.



  • @paul1149 I've had similar problems with both 1.14 and the 1.15 snapshot and filed the details in vivaldi bug VB-37418 .

    Pages like www.reuters.com are barely usable in vivaldi because the browser is so unresponsive but work perfectly on firefox side-by-side on the same machine.



  • @JSJB , I've had few problems with 1.15. Last evening it did start doing the misplaced cursor thing. I had been doing something with V, I forget what. It was acting like Windows progs often do, as if it were running out of RAM or something. I simply closed and reopened, and it began working fine again. Reuters seems to work fine here, just now.

    Have you tried renaming your user profile to see if that makes a difference? If so, there's a problem there. Or you could disable half the extensions at a time, to see if that frees it up.

    Specs?



  • @paul1149 When I installed I had wiped out the entire .config/vivaldi-snapshot, read in the bookmarks from an html file and still had performance issues.

    I should mention that I saw similar performance issues with chromium 62.0.3202.89-1 on which vivaldi is based.



  • @jsjb said in 1.14 massive problems:

    Pages like www.reuters.com are barely usable in vivaldi because the browser is so unresponsive

    Then there is clearly something wrong locally for you. This is not a systemic V fault, coz following my seeing your post i went to your US Reuters link & spent several minutes productively & efficiently browsing it. I then changed to its UK address & repeated the process. It all worked beautifully for me.

    Btw i am an active user of uO; these are my settings for that site [fyi just in case there's any nasty code active on that site that might be affecting you if you run V "naked"]:

    0_1518390365660_20180212_001.png

    0_1518390381130_20180212_002.png

    EDIT: The testing above was done in latest Snapshot 1.15.1094.3. Just now i have finished additional testing of the US Reuters site, but this time in latest Stable 1.14.1077.45. once again it was all excellent [this time i also tested video on that site; excellent].



  • @steffie Perhaps there's something locally that affects chromium-based browsers but all the sites and performance tests work great with firefox 58. If it is a local problem, it's limited to chromium-based browsers only.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.