Vivaldi will not re-open



  • After using Vivaldi ok and closing it, when I try to launch it again a while later nothing happens, either by clicking the icon on the desktop or right clicking it and selecting Open from the menu. I am using Windows 8.1 and Vivaldi 1.0.129.2 (Developer Build). Was ok until I tried that version.



  • Have you checked with Task Manager (Ctrl+Shift+Esc should open it, unless it has changed on Win8) or Process Explorer to verify that all vivaldi.exe process instances from your previous Vivaldi session have actually closed? If not, you can kill any remaining instances and then try restarting Vivaldi. (Of course if you have rebooted since the last session, this won't be the issue.)



  • Use your task manager to kill process. It happens sometimes



  • Thanks, that has cured it. But do I have to use task manager after every use of Vivaldi? Can this be cured for a later update?



  • Glad that worked, but don't know if you will continue to have the problem. I haven't had it happen yet, but there have been several reports in the forum of Vivaldi processes remaining open after Vivaldi appears (visually) to have closed. Some have mentioned that closing via the Exit item from the menu (V button > File > Exit or File > Exit in the upper left corner) is more reliable than using the X in the top right corner (I think I might have even seen a post indicating the X method is know to be buggy, but I'm not sure).

    This is a very young browser developmentally, maybe not even considered at "beta" level yet, so there are lots of bugs to be still worked out.



  • I'l try the File- Exit method instead of the X and see how it goes. I will report back. Strangely enough, since I used Task manager the problem hasn't reoccurred, I've managed to open and close it several times without a problem.



  • That was tempting fate! Having just said that I had to resort to Task Manage to open it again.



  • I am now using TP3 and still have this problem - after closing Vivaldi it only opens if I first use Task Manager to close it. Surely something is still not right here!



  • I don't have any good ideas about your situation, except that it has happened so consistently for you while it only seems to be more occasional and random for others, that I have to wonder if there might be a complicating factor on your machine. Can't think what it might be, though.

    You haven't mentioned much about your system but I notice you're on Win8.1 and in another thread you were using 64-bit Vivaldi. Might not reveal anything, but maybe post back with more details about your machine, and anything you can think of that might be out of the ordinary.

    Depending on how much you want to try to troubleshoot it, there are a couple of things I can think of to try if you haven't already:

    • fresh standalone installation to a different folder (to get away from anything a little buggy/corrupt in the current installation)
    • 32-bit Vivaldi, which is said to be more developed and less buggy



  • I think it needs a while to close. When I close Vivaldi and reopen it right away (because I forgot to check something i.e.) I usually need to resort to the Task Manager, when I close it and try to open it a good while later I think it happens less frequently/very rarely.


  • Moderator

    I had the zombie process bug before TP2, but on TP2 I deleted my profile and started a new. Maybe the problem is still present because of problems kept on the profile.



  • I should say perhaps that it doesn't happen every time. Someone else in this thread has suggested it's a time thing, so I will give that a go and monitor the time period - if that's at the root of it. If it's any help, although I had been using the 64-bit version for a while, the problem persisted when I went to TP3, which was a 32. I am now using 1.0.167.2. I am willing to go through the process of deleting the whole lot and starting afresh with a new installation, but how do I save all my bookmarks?


  • Moderator

    Saving that file named Bookmarks in your user folder.



  • @PeterCollyer:

    I should say perhaps that it doesn't happen every time. Someone else in this thread has suggested it's a time thing, so I will give that a go and monitor the time period - if that's at the root of it. If it's any help, although I had been using the 64-bit version for a while, the problem persisted when I went to TP3, which was a 32. I am now using 1.0.167.2. I am willing to go through the process of deleting the whole lot and starting afresh with a new installation, but how do I save all my bookmarks?

    Try to start vivaldi deleting current session, current tabs and last session last tabs before launch it.

    Should be enough to start it w/o any ghost process. Something that happens when vivaldi is restarted after a crash or after being forcefully closed trough the task manager.



  • The way i fixed this was to go to appdata -> Local -> vivaldi and deleted current session and current tabs i think they were called

    everything was perfect after this.



  • Thanx gdveggie and An_dz, have saved my bookmarks and deleted the rest, done a clean install of the latest 64bit version and the problem of it not re-opening has been cured. The only complaint now, and for me it's a minor one, is that it doesn't launch full size, but I see I'm not the only one to have that problem. It's now my default browser!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.