Notifications Selected on Opening


  • Moderator

    1. Drag the mouse over the bell icon
    2. Click the bell icon

    0_1517607323522_Selected Notifications.png

    This quite often happens accidentally for me.


  • Moderator

    Has anyone else come across this?



  • Yeah, happens semi-frequently, but compared to all the other long standing bugs on the forum this is really minor.


  • Moderator

    It happens to me not so often.



  • @lamarca It happens by chance, but Pesala wrote down how to recreate it and you can recreate it 100% of the time.

    Go over the bell icon and move slowly outside with your cursor until it jumps from pointer to regular shape, then click and hold and drag over the bell icon. You will notice the cursor becomes a caret, which in return highlights the text in both the notifications and the chat dropdowns. Nobody does this on purpose of course, therefore it only happens rarely and only the most dedicated users get annoyed by it. Everyone else won't care.


  • Moderator

    @luetage This appears to be a side effect of a long-standing problem which, to be fair, I'm not sure has ever been formally reported as a bug.

    It takes a very small lateral movement of the mouse (very small) to cause it to highlight a letter or word when clicking, say, a shortcut in the forum interface. Once that highlight appears, it is nearly impossible to get rid of it. You have to click on the link or very near it to make it vanish. Pretty much nothing changes it. If the link has a dropdown, the content of the dropdown gets highlighted, too. I don't think it would hurt to report the bug. It really ought to be looked at.



  • @ayespy Yes of course, like everything else too. Again, the highlighting stuff is minor. If you guys want me to, I write down a complete list of all bugs I have encountered on the forum... and I have collected quite the amount. Just to bring up one of the most obvious ones -- the bookmarking link in the profile dropdown still sends you to a site that doesn't exist. This bug and many other inconsistencies are fixed in the Vivaldi Forum mod extension, and I can take a look at this one too. But of course it would be best if it would be fixed for everyone by default, especially considering you two don't use the extension 😛

    The question is if any dev can spare the time to fix this. There is so much more important stuff to handle with the browser, or even the blog environment. Anyway, I'd say if they don't have the time to fix it all, other things should be fixed first.


  • Moderator

    @luetage Which would be why I have never bothered to report it in all these months. It's a minor annoyance to me - nothing more...



  • I came up with a fix for this, which will also be in the next version of the extension.

    #logged-in-menu.nav.navbar-nav.navbar-right {user-select: none;}

    This will prevent the selection of the dropdown text in logged-in menu (notifications/chats), when the dropdowns aren't expanded. You still can select the text wittingly, but accidental selection is being prevented.


  • Moderator

    That's a new one:

    0_1518259607313_Screenshot_2018-02-10_08-38-35.png



  • @lamarca How do I recreate this? I can only do this by selecting the elements on page, which is intended behaviour.


  • Moderator

    @luetage Of course I didn't select anything. Why should I do that? After reading a post I clicked on Categories and then ......



  • @lamarca I don't know 😕 But if we can't recreate it reliably, we can't fix it either. I have a feeling this is not related to the "bug" described by Pesala.


  • Moderator

    @luetage You don't know how to repro. Well neither do I. Somehow it might linked to Notification Selection.
    Unlike me, @Pesala can repro the issue.



  • @lamarca ^^
    I can reproduce the initial problem reliably (and so can you if you try), your problem seems to be different and unrelated. The category link is neither a notification nor a dropdown and opens a new page within ajax.


  • Moderator

    It happens again when backing to Categories.

    0_1518960214981_again.png


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.