Default search engine doesn't work if there is a matching suggestion from history or bookmarks



  • I have just done a clean install of Vivaldi 1.14.1077.41 x64, and now using the default search engine from the address bar doesn't work properly anymore. I didn't use to have this problem in the previous installation (of Vivaldi 1.13).

    For example: https://vivaldi.com/ is in my browser history. If I type just vivaldi into the address bar (and make sure to delete any auto-completion it might suggest if that feature is active), I should be taken to the search results for the query "vivaldi" of my default search engine. However, I'm taken directly to https://vivaldi.com/, because it's the first match from the results visible in the dropdown (even if I disable the actual dropdown).

    In other words, if the search query I'm trying to start from the address bar matches with any entry from the browser history or bookmarks, it will go directly to that entry, and not to the search results page I wanted. The only way I still get the default engine's search results from the address bar is if the search query matches absolutely nothing in Vivaldi's history or bookmarks.

    I would expect this only to happen if I disabled searching without search engine nicknames, didn't enable searching from the address bar, etc. — but in my view, all of these settings are correct and should allow me to search from the address bar regardless of whether I have relevant stuff in my history:

    • Address Bar > Address Auto-Complete: Disabled
    • Address Bar > Address Field Drop-Down Menu > Show Drop-Down when Typing: Disabled
    • Quick Commands > Include in Search Results > Bookmarks: Disabled
    • Quick Commands > Include in Search Results > History Entries: Disabled
    • Quick Commands > Include in Search Results > Page Actions: Disabled
    • Search > Search in Address Field: Enabled
    • Search > Allow Search Suggestions > In Address Field: Disabled
    • Search > Search Engines > Bing > Set as Default Search: Enabled
    • Privacy > Third Party Services > Search in Address Field: Enabled
    • Privacy > Third Party Services > Search Suggestions in Address Field: Disabled


  • This drove me so crazy that I did another clean re-install over the weekend. The behaviour is now gone and it works as expected again, with the exact same settings (the one I listed in the original post, at least; I'm not aware of having changed anything else that could be relevant).

    I seem to be having this problem repeatedly with Vivaldi: the browser behaving in ways which don't fit with the settings I made, and only respecting the settings after a re-install… maybe it's not even related to the settings themselves, but a general preference management issue?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.