Vivaldi Installer funktioniert nicht mehr



  • Hallo zusammen,

    da eine mehrstündige Recherche via Google und hier im Forum leider nicht zu einer Lösung führte, habe ich mich hier angemeldet in der Hoffnung, dass mir hier jemand helfen kann.

    Es geht um die Installation von Vivaldi (in meinem Fall irrelevant ob Stable oder Snapshot).

    Kurze Info zu meinem System:
    Windows 10 Pro 64 Bit
    Asus X99-A Mainboard
    i7 5820K
    64GB DDR4
    MSI GTX 1070 Aero 8G + Gainward GTX 970 Phantom II

    Das Problem:
    Ich starte das Setup, wähle aus, wohin installiert werden soll, ob Standalone oder per User, klicke auf "Accept and Install" und nach wenigen Sekunden bricht das Setup ab mit der Meldung "Vivaldi Installer funktioniert nicht mehr". Das Fenster, in dem die Fehlermeldung steht, gibt mir leider keine Möglichkeiten, weitere Details zu erfahren. Es gibt nur einen "Schließen"-Button.

    Bisher versuchte (aber erfolglose) Lösungsansätze:

    • Setup mit Administratorrechten ausführen
    • Vivaldi in anderen Ordner auf anderer Festplatte installieren
    • Vivaldi deinstallieren und Versuch, neu zu installieren
    • Alle Dateien und Ordner, die in Vivaldi in Verbindung stehen löschen (Installationsordner, Vivaldi-Ordner im Nutzerverzeichnis, temporäre Dateien, etc.) sowie Alle Einträge, die den Begriff "Vivaldi" enthalten aus der Registry löschen. Dann Neuinstallation -> selber Fehler

    Meine einzige Möglichkeit, Vivaldi überhaupt wieder zu "installieren" oder zu updaten, bestand zuletzt darin, Windows 10 x64 in einer virtuellen Maschine (Virtual Box) neu zu installieren und darin Vivaldi neu zu installieren, um anschließend die installierten Dateien von Hand auf mein Live-System zu kopieren und dort die alten Dateien zu überschreiben.
    Da es sich hierbei um ein sehr aufwändiges Verfahren handelt und ich denke, dass der Installer doch eigentlich kein Hexenwerk sein sollte, möchte ich hier um Hilfe bitten.
    Vielleicht hatte ja jemand anderes bereits dieses Problem und kann mir Tipps geben, was ich noch versuchen könnte.

    Hier ein Screenshot der Meldung:

    Hinweis:
    Manche User, habe ich gesehen, berichten z.B. von Fehlermeldungen, dass temporäre Dateien nicht entpackt werden könnten. Diese Meldung (aber auch ähnliche oder andere mit mehr Details auf die Ursache) habe ich noch nie erhalten und glaube auch nicht, dass es daran liegt, da ich komplette Schreibrechte habe (zumindest als Administrator), da es sich um meinen privaten Rechner handelt.

    Anfangs (vor einigen Monaten) hat die Installation auch problemlos funktioniert. Und irgendwann nach ein paar Updates ging dann nichts mehr.

    Vielen Dank vorab für jegliche Hilfe.

    Beste Grüße,
    Knopfmann


  • Moderator

    Es braucht kein Administratorkonto zum Installieren.
    Wenn du Vivaldi global für Alle installierst, holt sich Windows 10 schon die erhöhten Rechte durch Admin-Passwort mit dem Benutzerkontrollpopup (UAC).

    Ich habe ja schon einige Versionen installiert.
    Eine Stable für Alle Nutzer
    Eien Interne Vivaldi als normaler User
    mehrere Standalone im normalen Nutzer.Klappt alles fein.

    Sicherheitstools?
    Warum der Installer abstürzt, ist rätselhaft.



  • Hi Gwen-Dragon,

    danke dir für die schnelle Antwort.

    Als Administrator zu installieren war nicht meine erste Wahl. Ursprünglich hatte ich es als normaler Benutzer versucht, was, ganz zu Anfang, auch mal funktionierte.

    Sicherheitstools (Antivirus/Security Suiten, etc.) habe ich keine Installiert. Ich verwende nur die Windows-eigene Firewall und die Sicherheitsfunktionen meines Routers.

    Ich bin dem Problem zwar nicht auf die Schliche aber ein bisschen näher gekommen. Und zwar habe ich mich mit einem neuen Benutzer angemeldet und unter diesem den Browser standalone installiert. Dort lief es problemlos durch. Nun habe ich meinen "User-Data"-Ordner in das Verzeichnis des 'Neuer Benutzer'-Vivaldi kopiert und gestartet und Vivaldi läuft. Die Frage ist nun noch: Funktioniert jetzt auch das Update wieder? Diese Frage ist jedoch rethorisch. Das muss ich selbst klären.

    Nichtsdestotrotz bin ich weiterhin an einer Lösung interessiert, da ich Fehler gerne behebe anstatt sie zu umfahren und zum anderen, weil es auch für andere User mit dem gleichen Problem interessant sein könnte.

    Nochmal vielen Dank.

    Knopfmann



  • Mahlzeit. Hab mich auch mal registriert extra wegen diesem Problem.
    Auch bei mir lässt sich Vivaldi nicht mehr installieren, ich komme mit diesem Problem auch nicht weiter, nichts funktioniert. Das schlimme dazu ist noch, ich hab wahrscheinlich noch wesentlich weniger Plan von der Materie wie mein Vorgänger hier. Was tun ?



  • Hi delle59,

    hab deine Nachricht erst jetzt gesehen, daher die späte Antwort.

    Also bei mir ist das Rätsels "Lösung", die, dass ich einen neuen Benutzer eingerichtet habe und unter diesem nichts anderes gemacht habe (und mache) außer Vivaldi zu installieren. Dort funktioniert es einwandfrei.
    Wenn ich nun Vivaldi unter meinem normalen Benutzer aktualisiere, erscheint der Fehler zwar wieder, allerdings ist das Update dann trotzdem installiert. Wenn ich den Browser starte und auf Updates prüfe, dann sagt er, dass ich die neueste Version benutze und zeigt auch die korrekte Versionsnummer an.

    Eine Vermutung, woran es bei mir liegen könnte, habe ich inzwischen. Ich benutze eine alternative Shell namens bbZero (basierend auf bbLean bzw. blackbox/*nixbox). Dieses Programm ersetzt den gesamten Desktop, die Taskbar und das Rechtsklickmenü auf dem Desktop. Das alles (und nach Bedarf mittels Plugins auch mehr) stellt das Tool selbst bereit. Der Punkt ist jedoch, dass das Tool die Windows UI zu gewissen Teilen deaktiviert, wodurch sich zum Beispiel die Windows 10 Systemsteuerung und Edge nicht mehr starten lassen. Ich nehme stark an, dass auch das Vivaldi-Update-Tool nach Installation der Dateien auf eine Ressource der deaktivierten UI zugreift. Da diese dann nicht verfügbar ist, könnte zum Absturz führen. Getestet habe ich das noch nicht, weil es mit nicht unerheblichem Aufwand verbunden ist und ich eine Lösung für mich gefunden habe.

    Da du vermutlich diese Shell nicht verwendest, empfehle ich einfach, einen neuen Benutzer anzulegen und mit diesem eine Standalone-Installation auszuführen. Wenn das auch nicht klappt, ist irgendwas grundsätzlich nicht in Ordnung. Da kann ich dann aber auch nicht mehr weiterhelfen.

    In jedem Fall viel Erfolg bei dem Problem! Hoffe, du bekommst es hin.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.