Remove white / grey flashing when starting browser with dark theme



  • Problem:

    1. Set any dark theme with or without the dark background image, or just color.
    2. Close the browser
    3. Run the browser
    4. At the period before drawing browser interface (the microsecond thing) happened some white / grey flashing with a logo of Vivaldi, but before it for millisecond happen to flash of something white. You mostly don't see it, because it blinks one time only and very fast, but it hurts eyes...

    Please fix. Happen on all Vivaldi versions (current beta 1.14, and stable 1.13)

    What should be:

    1. You have dark theme at Vivaldi
    2. You running the browser
      3.) no white flashing light for the microsecond, should be replaced with dark one...
      4.) Remove/replace Vivaldi logo to something user specific (if the user has blue theme colors, then this logo should be blue if black -> then black...

    Why is it a problem?

    1. ) Microsecond flashing black -> white -> black is very painful for eyes.
      2.) Make mostly impossible to work with Vivaldi if you frequent restart browser.


  • Close your eyes while restarting the browser? :P
    Anyway, I found no way to change this. You have access to the background color of the logo, you can change it in browser.html. The first flash is gray in my case, not white, but I don't know where to set it.


  • Moderator

    The gray background has been introduced months ago as a fix for whitish flicker after opening a tab.



  • @luetage said in Remove white / grey flashing when starting browser with dark theme:

    Close your eyes while restarting the browser? :P

    It's the only option, the problem is when you forget it.

    alt text

    xDDD


  • Moderator

    I always am concerned about accessability (#a11y) on Vivaldi browser.

    I will check in internal chat if the background can be changed to reduce the short flicker.


  • Moderator

    @desperand Please report as a bug.
    Such flashing should not happen and be fixed.


    How to do a bug report for Vivaldi

    Report each bug separately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    Add some information which security tools you use.
    If you have problems with video or audio give us information about your installed codecs and graphics
    card/GPU.
    Add a exact link to the page where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as
    attachments and it will be added automatically to bug report.

    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX
    bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!




  • @gwen-dragon Wouldn't it just be possible to make it default gray (just like now) and introduce a simple setting for advanced users who can input a color of their own choosing? Or just use the accent color of the current theme. I don't know why we still have these issues 2 years later, it's such a simple thing.



  • I have sent bug reports few moments ago with the video demonstrating the issue...
    At Linux situation much worst (i noticed it after using on both system) at Linux, you even see before loading image with Vivaldi logo a full white display.

    Here is a video btw: https://youtu.be/uwYuFiuBaT0



  • @desperand
    There is also another bug on your video that i have too. Vivaldi doesn't start maximized. At the third time (about 0:33) it opened maximized, then again not maximized till seventh time (1:35)



  • Until this is fixed natively in Vivaldi, you could do this with custom css by changing the background color of body. It's specified inline in browser.html, like luetage said, so if you were to do this using a custom css file, you'd need to use an !important modifier for it to overwrite the default. Otherwise you could just change the value directly in browser.html, but I think it's probably best and generally recommended do still do it with a custom css file.

    You could make it black as simply as,
    body {background-color: black !important;}

    Or you could have it inherit the current theme's background color with,
    body {background-color: --colorBg !important;}

    This was something I had changed in AFV very shortly after I noticed the splash, as it felt intrusive. So if you need further reference for the css, see here at line 19



  • @cyhnzs I noticed that too since maybe v1 of Vivaldi, but I don't constantly use Vivaldi browser, so it was not a problem for me by now. But right now this is a problem for few weeks while I'm using Vivaldi only... Very annoying thing...



  • @tiamarth first of all thank you very much for your link and as i got for your work (about theme). The theme looks good, and your fix solves my problem, flashing not so painful because it's not bright anymore.

    And I'm really enjoying using Arc grey theme. Really nice one.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.