[1.14.1077.25] Bug: Broken Currency Format for GBP Pound (£) (Intl.NumberFormat)



  • I just tried to submit a bug, but I'm not sure whether it went through properly - there was an issue communicating with Google recaptcha being blocked by uMatrix, and then I had a crash as it tried to submit! 😞

    Here is what I tried to submit - if it didn't get through, let me know and I will re-submit.

    Summary *

    Broken Currency Format for GBP Pound (£) (Intl.NumberFormat)

    Vivaldi: 1.14.1077.25 (Official Build) snapshot (64-bit)
    OS: Ubuntu 16.04
    Also,
    Vivaldi: 1.14.1077.3 (Official Build) (64-bit)
    OS: Windows 10 (in a VM)

    I have checked this and it works as expected in:
    Chromium : Version 64.0.3282.99 (Developer Build) Ubuntu 16.04 (64-bit)
    Firefox: 59.0b4 (64-bit) on Ubuntu 16.04
    Microsoft Edge 41.16299.15.0 on Windows 10

    Similar (but not same) issue reported in Chromium bug log here:
    https://bugs.chromium.org/p/chromium/issues/detail?id=648853&q=Intl.NumberFormat&colspec=ID Pri M Stars ReleaseBlock Component Status Owner Summary OS Modified

    Describe in steps how to reproduce the bug

    1. Enter following js in console:
    var toGBP = function(val) {
      var f = new Intl.NumberFormat('en-GB', {
        style: 'currency',
        currency: 'GBP', 
        currencyDisplay: 'symbol',  // commenting out this line makes no difference
        minimumFractionDigits: 2
      })
      return f.format(val)
    }
    
    1. Then enter:
    toGBP(12345)
    

    What did you expect to happen *

    Console outputs:

    "£12,345.00"
    

    What had actually happened *

    Console outputs:

    "GBP12,345.00"
    
    (See above for version and OS)

    Thanks,

    d


  • Moderator

    Same on Windows.

    May be a Chrome/64.0.3282.121 bug?



  • That's what I thought at first, so I installed Chromium 64 (ppa:saiarcot895/chromium-beta) and the issue was not present.


  • Moderator

    @cheekybuddha And which Chrome/64.xxxx is this (ppa:saiarcot895/chromium-beta)?


  • Moderator

    @gwen-dragon said in [1.14.1077.25] Bug: Broken Currency Format for GBP Pound (£) (Intl.NumberFormat):

    Chrome/64.0.3282.121

    I could not find a Chrome/64.0.3282.121 build on the web to compare with current Vivaldi 1.14. Comparing to Chrome 64 BETA is useless, it has a lower version number.

    But you JS snippet works fine in Chrome 66.0.3334.0.


  • Moderator

    You may report the bug to Vivaldi!


    How to do a bug report for Vivaldi

    Report each bug separately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    Add some information which security tools you use.
    If you have problems with video or audio give us information about your installed codecs and graphics
    card/GPU.
    Add a exact link to the page where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as
    attachments and it will be added automatically to bug report.

    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX
    bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!



  • Moderator

    I confirmed internally bug VB-36846 "Broken Currency Format for GBP Pound (£) (Intl.NumberFormat)"



  • @gwen-dragon
    The Chromium version is noted in the Summary above: Version 64.0.3282.99 (Developer Build) Ubuntu 16.04 (64-bit)

    I'll see if there is a newer ppa, but I didn't really want Chrom(e|ium) on my system in the first place!!

    It looks like the bug report went through: [Jira] (VB-36846) Broken Currency Format for GBP Pound (£) (Intl.NumberFormat)

    (Ah, I see you saw it too!)



  • @cheekybuddha
    The dev ppa (ppa:saiarcot895/chromium-dev) installs version 65: Version 65.0.3298.3 (Developer Build) Ubuntu 16.04 (64-bit).

    That also behaves as expected:

    toGBP(12345)
    "£12,345.00"
    

  • Moderator

    @cheekybuddha I will update the bug in bugtracker with this info.
    Done.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.