Cookies and passwords won't persist after updating to 1.13.1008.44



  • So today I got a prompt to install 1.13.1008.44 as the latest stable version. After installing, I had lost all of my cookies and stored passwords. I tried recovering by copying from an old profile backup but no matter what I do, on every restart all cookies and passwords are removed. Other settings seem unaffected by this (for example bookmarks and history still exist).

    As the last measure, I deleted the profile ~/Library/Application Support/Vivaldi and started fresh. But the problem still persists! If I save a password and go to "Privacy settings", it will show no passwords were stored. Cookies work until I restart the browser, then they are all gone. The cookie setting is set to "All" in privacy settings, and "Save passwords" is checked.

    I'm using the latest macOS (10.13.2).

    What do I do now?


  • Moderator

    Pretty sure even in Mac, the profile is the "Default" folder. Someone correct me if I'm wrong.



  • The profile is located at

    /Users/Username/Library/Application Support/Vivaldi/Default



  • Yeah I typoed the folder, forgot the "Library" part in this post. Point is, deleting it did nothing to fix the problem and the browser is still broken.



  • It seems this problem has resolved itself automatically when I upgraded to 1.14.1077.41. Don't know why, but now it seems to work again. Hoping it keeps working and I don't need to switch to Firefox, my workflow with it is not quite there yet.


  • Moderator

    @nicd Fine, it works.
    Thanks for feedback.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.