スナップショット1.14.1072.3に更新後のブラウジングにおけるパフォーマンス低下



  • 1.14.1072.3に更新するまでは問題は特になかったのですが
    更新後、ブラウジングのパフォーマンスが著しく低下しました
    CPU使用率がブラウジング時に20~30%近く上昇し、ページの表示も時間がかかるようになりました
    また、広告ブロックの拡張機能(content block helper)を入れているのですが、
    最初のページだけ100%その設定が反映されません
    次のページからは反映されるようになります

    当方で調べたところ、今回のアップデートでChromiumが64.0.3282.86 にアップデートされた際に
    「メルトダウン」「スペクター」に対応になったことに関係があるのでは無いかと思っております

    1.14.1047.3に書き戻したところ、トラブルは無くなりました
    やはりChromium由来の問題でしょうか?



  • まず、投稿場所を間違えていましたこと、お詫びいたします
    また、早々のご連絡ありがとうございます

    ご意見を伺い、もう一度最新版のスナップショットに更新しましたがやはり同様の状態となります
    PCの故障も疑ったのですが、前投稿の通りバージョンを下げることで解消しましたので違うとの判断です

    簡単にPCの構成ですが
    CPU:AMD PhenomIIx6 1090T(3.2GHz 6コア)
    Motherboard:ASUS M4A88T-V EVO
    メモリ:DDR3 1600 16GB(使用中:10GB 空き:6GB)、仮想メモリ:0
    OS:windows server 2012R2
    GPU:オンボード(radeon HD4250)
    常駐ソフトとしてAVG business edition(vivaldiは例外に設定済み)
    仮想OSとしてVMware playerが5つ稼働しており
    未操作時のCPU使用率はおおむね40~50%です
    OS本体の「メルトダウン」「スペクター」対応パッチはまだ適用しておりません

    この状態でvivaldiを起動しページを開き終わる間、CPU使用率が80~90%、場合によっては100%になります
    同じく、拡張機能の広告ブロック機能は最初のページに適用されなくなります
    ページをリロードすると一応は適用されるのですが、一部コンテンツはフォームデータが残るようで
    うまく機能しなくなります
    当方はプログラムには疎く、良い解決方法が見つからなかったための投稿でした
    何か良い方法がございましたらご教授くださいますようよろしくお願いいたします



  • ご提案ありがとうございます
    server2012R2はwindows8.1相当になります
    今までサーバー特有のトラブルが無かったのでうっかりしておりました
    サーバー特有の問題の可能性も否定できないので
    クライアントでも試してみたいと思います

    少々お時間をいただくかと思いますが
    検証が済みましたら報告を上げたいと思います
    サーバー:windows srver 2012R2 64bit
    クライアント:windows7 ultimate 64bit / windows10 pro 64bit



  • Vivaldi.1.14.1072.3.x64における、拡張機能・ブラウジングパフォーマンスについての検証結果報告
    (Vivaldi.1.14.1047.3.x64との比較)
    拡張機能:content block helper(広告ブロック)

    1.windowsserver 2012R2 64bit
    拡張機能:最初のページだけ拡張機能が反映されない
    パフォーマンス:ページ読み込みの際にCPU使用率が20~30%程度増加

    2.クライアントA(デュアルブート)
    windows10 pro 64bit
    拡張機能:最初のページだけ拡張機能が反映されない
    ページ読み込み時のCPU使用率が5%程度増加
    windows7 ultimate 64bit
    拡張機能:最初のページだけ拡張機能が反映されない
    ページ読み込み時のCPU使用率が5%程度増加

    3.クライアントB(デュアルブート)
    windows10 pro 64bit
    拡張機能:最初のページだけ拡張機能が反映されない
    ページ読み込み時のCPU使用率が5%程度増加
    windows7 ultimate 64bit
    拡張機能:最初のページだけ拡張機能が反映されない
    ページ読み込み時のCPU使用率が5%程度増加

    以上をまとめますと、アップデートによるパフォーマンス低下はクライアントPCにおいては
    軽微であるという結論となりました
    また、serverにおけるパフォーマンス低下は原因は不明ながら
    何らかのバックグラウンド処理によるものであると思われます
    ただ、一部の拡張機能に不具合が出ているのも事実ですので、
    その点につきましては制作者の方にコンタクトを取ってみようと思います

    このたびはお騒がせをして申し訳ありませんでした



  • ついでにgoogle chromeでも試してみました
    63.0.3239.132での拡張機能は正常に動作しました


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.