1.14.1072.3 crash



  • Hi, I updated to 1.14.1072.3 on my workstation today and got a lot of crashes.
    Update speed dial with F5 leads to crash reproducible.
    It crash with a clean profile also.
    I work with 1.14.1072.3 on my laptop flawlessly since yesterday, no idea what happen on my workstation. :/

    Opensuse Leap 42.2 x86_64
    Intel i5 3570K 16 GB RAM
    GTX 760 4 GB /Display card
    GTX 670 2 GB
    Driver 384.111
    Vivaldi 1.14.1072.3 (Official Build) snapshot (64-bit)

    Cheers, mib
    EDIT: Try to debug with GDB but then it does not crash. :)
    I think I start vivaldi-bin and not the start script, may it is something with the script.


  • Moderator

    May be you had some SpeedDials which contain inline video? I remember for me Arte.
    I had this some internal 1.14 versions ago.



  • I have two animated .gif but remove them does not change anything.
    I hope for the next update, was absolute stable on all systems I use.

    Cheers, mib





  • @steffie
    Hah cool, if you can reproduce it is easier to catch bug for the developer.

    Summary: Crash with F5
    Key: VB-36600

    I reported it a few minutes ago.

    Cheers, mib



  • @mib2berlin I still cannot update speed dial thumbnails in 1.14.1077.3, without crashing V-SS. I'd hoped that the chromium change to 64.0.3282.97 in the new SS might have fixed it, but no. Hence, i do hope the V Devs can resolve this bug fast pls.


  • Moderator

    @steffie I guess I'll have to reorganize my office a bit and plug in my Mint box and see if I can reproduce it - see if it's Linux-wide, or something particular to your system.



  • @ayespy We already know this bug is not unique to me... https://forum.vivaldi.net/post/186584 [ie, 3 posts up, above this one].


  • Moderator

    @steffie To be fair, I did not say "unique," but rather "particular." In other words, how generic to Linux is it, and how dependent on environment. You have a fair number of special circumstances at your end, none of which I share, so an experiment might be instructive.



  • @ayespy Was only trying to stop you having to rearrange your furniture ;-)


  • Moderator

    @steffie Hmm. Well, it works on my Mint18 with no extensions, no VPN, no blockers or security apps. Sorry I couldn't make it easier to diagnose.

    Disclosure: I don't have the 1.14 Snapshot on that box. I was only able to test the Stable and the internal tester version.



  • @ayespy said in 1.14.1072.3 crash:

    I don't have the 1.14 Snapshot on that box

    Ah -- sorry, but that largely invalidates your test. This bug ONLY arose with the last 2 Snapshots. I had no trace of it before those.

    In fact, after i post this, i'm going to close SS, copy its bookmarks file to my Stable, & try the TN refreshes there. If it crashes, then it's my problem. If it does not crash, then it's Vivaldi Snapshot 1.14.x's problem.
    #########################################

    UPDATE: With my SS's bookmarks file copied to Stable, i was able to update dozens of SD TNs, both in bulk [F5] & individually via TN icon. ZERO crashes of Stable.

    Conclusion: The SS 1.14x series has a bug, presumably caused by the big changes of chromium 64.


  • Moderator

    @steffie Well, the internal test version is only 1.4.1078.1, so I'm one minor version increment ahead of you. Either it was fixed in the last day, or I was unaffected by it. I can't put the snapshot on my Linux box, because it thinks internal test version and Snapshot are the same thing. I agree my test is open to question - but perhaps not entirely invalid.



  • @ayespy MODIFIED Conclusion: The SS 1.14x series has a bug, presumably caused by the big changes of chromium 64... OR... my profile [not refreshed for a very long time coz all has been good] is now corrupt.

    I've just done a different test, & it [natch, sigh] has severely muddied the waters. I copied that same BM file into the Default folder of my Manjaro VM's 1.14.1077.3, which has NO extension installed [all my previous posts were for my real OS, in which as usual i have lots of extensions]. In the VM's SS, with that same BM file, i CAN update the SD TNs with NO crashes.

    Now i shall begin incrementally installing my extensions one by one in the VM, to see if i can pin down a specific extension as implicated.
    #########################################

    EDIT: Another UPDATE: I do so wish that Real Life would make up its mind. In the time it took to post my previous update, V-SS in the VM CRASHED during SD TN F5 [still no extensions therein]. I've now repeated that same test, using different SDs, & also using the individual TN update icons not F5. Each of these tests also crashed.

    This appears to re-validate the original reports by @mib2berlin & me that it's these 2 1.14 SS's at fault, not our/my profiles.
    #########################################

    EDIT: Final UPDATE: Back in the VM's SS, i removed my real V's BM file, & restored the V default BM file, then initiated SD TN updates... & once again V crashed [with virginal profile]. It's over to the Devs now.



  • @steffie Well, I do not get a crash on Linux Mint 18.3.

    My speeddial is a mix of generated thumbnails and icons from @D0J0P 's thread.
    Also a mix of thumbnails and folders.

    Not sure it matters, but one thing you haven't mentioned in your tests is whether or not you activated sync? In my case I have sync between Mint and Win 10 Pro - but on a dual boot pc, so only one is active at any time.


  • Moderator

    @mib2berlin said in 1.14.1072.3 crash:

    VB-36600

    Internal tester could not reproduce it on Ubuntu 16.

    And i can not confirm on Ubuntu 17.10 GNOME.


  • Moderator

    @steffie One of our internal testers, after several attempts on different machines and under different conditions, has managed to reproduce this on Mint18 by syncing with a dirty Win7 profile. (no one could reproduce it clean). At first, he got no logs or traces, but he finally did manage to produce some traces from Linux terminal & GDB, and has attached them to your (now reopened) bug. It looks like this may be reproducible and debuggable.



  • @tbgbe No sync [don't believe in it].



  • @ayespy Well thank goodness for that. I was feeling forlorn that, other than @mib2berlin, nobody else could get this, yet i get it [as documented above] in current & previous SS of my Tower's real Manjaro KDE, VM Manjaro KDE, & [just tested now] Lappy's real Manjaro KDE. Yesterday i was fully ready to accept that my profile was finally corrupt [after >year of great behaviour], until i did that extra test in VM Manjaro KDE with default installation & it also crashed.

    I've just done another new test, & this time the V-SS default installation did NOT crash when updating SD TNs. It was in another Manjaro VM, but this one is Xfce not KDE. So, i wonder... all the crashes occurred in KDE, the only OK was non-Xfce.

    As time permits today i shall test this in some of my other VMs... non-Manjaro KDE & non-KDE, & will report back later.



  • @steffie Incremental Update: Still in Tower's Manjaro Xfce VM [tested previously with virgin profile which did not crash], i have now copied my real Bookmarks file into its Default folder & retested. After dozens of SD TN updates, F5 & icon, it has still not crashed.

    This, together with yesterday's test of the same real BM file copied into Tower's Stable V-SS, imho proves that my real BM file is innocent.

    Hence now, the emerging [but still not sufficiently proven] indicative commonality seems to be use of the KDE desktop environment. My next tests in my other VMs will be interesting to perform, to provide more data points.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.