1.14.1072.3でtwitterのビデオが見れなくなりました。


  • Moderator

    検証環境
    Linuxmint18.3
    1.14.1072.3 (公式ビルド) snapshot (64-bit)

    https://twitter.com/zyxwjp/status/953613916025663488

    アップデートを行ったところtwitterのビデオが再生出来なくなりました。
    0_1516194682544_zyx_128.png

    前のバージョンでは問題なく再生出来ました。(画像は1.13state)
    0_1516194857785_zyx_129.png



  • @zyxwj Mac版では問題なく動画が再生できました!動画の滞り問題も解消された(?)ようで、特に滞りも見られませんでした。

    【使用環境】
    Vivaldi Snapshot 1.14.1072.3
    macOS High Sierra 10.12.3


  • Moderator

    linux版はバージョンを1.14.1064.3に戻したらtwitter動画の再生出来るようになりました。
    windows10 32bit環境でも問題なかったです。

    @kyu3a
    報告ありがとうございます。
    linuxの独自のバグっぽいですね。


  • Moderator

    どうやらtwitterに限らず動画関連が駄目ですね。

    プライムビデオ
    0_1516226500260_zyx_131.png

    youtubeでh264がサポート外に。

    0_1516226690857_zyx_132.png


  • Vivaldi Team

    @zyxwj

    ご報告ありがとうございます。
    上記各動画プラットフォームでそれぞれテストしてみましたが、
    再現はできず、エラーメッセージ等も確認できませんでした。

    引き続きモニタリングを行なってみます。
    何か他にお気付きの点等あれば共有いただければと思います。


  • Moderator

    @ahojo
    何度か上げ下げして確認したんですがバージョン下げると見られ、上げるとダメでしたが、そちらで再現しないとの事なのでプロファイル及び設定を見直します。


  • Moderator

    追加情報です。

    画像左が1.13state右が1.14.1072.3の比較画像
    1.14は新規プロファイルでvivaldi://flagsで初期設定しています、h264が機能的に死んでいるようです。関連のパラメーターを変更しても変化なし。

    1.13のコマンドライン

    /usr/bin/vivaldi-stable --always-authorize-plugins --enable-blink-features=ResizeObserver --flag-switches-begin --ignore-gpu-blacklist --flag-switches-end
    

    1.14.1072.3 のコマンドライン

    usr/bin/vivaldi-snapshot --profile-directory=pro2 --always-authorize-plugins --enable-blink-features=ResizeObserver --flag-switches-begin --flag-switches-end --disable-smooth-scrolling
    

    0_1516278891881_zyx_135.png

    0_1516278914647_zyx_136.png

    chromium ver64との相性

    • chrome : 64.0.3282.99をインストールしましたがこちらは問題なし。
    • chromium Version 64.0.3282.85 問題なし。

    PCの環境的に動画再生に問題が無いように思いますが、他に見落としている点があればアドバイスお願いします。


  • Moderator

    1.14.1072.3の更新履歴を見ると動画関連の修正が入っていますね、この修正が私の使っている環境と相性が悪い気がします。

    https://jp.vivaldi.net/2018/01/16/1-14-1072-3/
    [Linux] 立ち上げ時のクラッシュを防ぐために最大FFmpegバージョンの定義づける VB-36113
    [Linux] メディア用に適切なFFmpegライブラリがない場合に警告する VB-36111


  • Vivaldi Team

    @zyxwj

    追加確認、検証ありがとうございます。
    社内で上記共有した上で、引き続きモニタリングを行なってみます。
    何かお気付きの点等あれば教えていただければと思います。
    よろしくお願いします。


  • Moderator

    Fix:

    mkdir -p $HOME/.local/lib/vivaldi/ 
    cd /tmp 
    wget https://repo.herecura.eu/herecura/x86_64/opera-developer-ffmpeg-codecs-65.0.3298.3-1-x86_64.pkg.tar.xz 
    tar xf opera-developer-ffmpeg-codecs-65.0.3298.3-1-x86_64.pkg.tar.xz usr/lib/opera-developer/lib_extra/libffmpeg.so --strip 4 --warning no-unknown-keyword 
    install -Dm644 libffmpeg.so "$HOME/.local/lib/vivaldi/libffmpeg.so"
    
    wget https://gist.githubusercontent.com/ruario/3c873d43eb20553d5014bd4d29fe37f1/raw/f70f1ce62bc9e5d89dbeb56a8d67a8ce0827a4a4/latest-widevine.sh 
    sudo bash latest-widevine.sh
    

  • Moderator

    Gwen-dragonの説明で無事見られるようになりました。
    これってどこかに説明あったんでしょうか?ハマりポイントですね。

    @gwen-dragon Thank you It was fixed.


  • Moderator


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.