Vivaldi Won't Restore Last Session



  • I'm using Vivaldi 1.13.1008.40 64 Bit. On Windows 10.

    In Settings, I have it set to restore the last session at startup, but I always just get the start page. Every time I start Vivaldi anymore, I have to click the little trashcan in the top rights and manually restore my "Window with 17 Tabs".

    I don't have any other sessions open, and this problem was present in the 32 Bit version (I literally just switched to 64 to see if it would fix the issue) and the last several versions (I think back to Vivaldi 1.8 when I first started using it). I've rebuilt my computer a few times, and whenever I install Vivaldi for the first time, it restores the session just fine for a while, then eventually breaks.

    Is anyone else having this issue? Are the devs aware? Is there a fix?


  • Moderator

    @barondando If you have it set to stay live in the background for push actions after you close it (that's a flag), or if you have an extension that continues to run after shutdown, this will prevent Vivaldi from storing the session as "active" and prevent it from starting up with "last session."



  • @ayespy Thank you SO much! It was a combination of both those causes.

    I went ahead and explicitly disabled the background push actions flag, and realized my VPN extension that liked to run in the background. After disabling it session restore is working as it should!



  • @ayespy I to am having this same issue...Vivaldi won't restore last session anymore!! Will you please state exactly how or where "Stay Live In The Background For Push Actions" is located...so that my see if that solves this issue for me as well...I tried google but to no avail!! Thanks



  • @raah
    Hi, copy > paste
    chrome://settings/?search=hard
    in address field and disable "Continue running background apps when Vivaldi is closed"

    Cheers, mib


  • Moderator

    @raah There's also vivaldi://flags/#enable-push-api-background-mode



  • @ayespy
    Hi, does "Default" of this flag it is enabled per default?

    Cheers, mib



  • @mib2berlin
    @Ayespy

    I appreciate your fast response...your awesome!....After a simple restart of my computer....presto magic...problem solved 😊😃


  • Moderator

    @mib2berlin I think it used to be off by default, and now for some reason is on by default. I'm not 100% sure, however. Several people recently have found it on when they did not consciously turn it on (though an extension could have, I believe).


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.