Bizarre Problem



  • Seriously baffled. Dunno what the heck happened, but here's what I get now when trying to open Vivaldi:

    WTF

    Address bar won't accept input. No menus or options available. Right-clicking does give menu, but nothing seems to work.

    Debug log looks like this:

    [1016/233611.927:ERROR:process_info.cc(632)] range at 0x235523b400000000, size 0x296 fully unreadable
    [1016/233611.932:ERROR:process_info.cc(632)] range at 0x235523d400000000, size 0x296 fully unreadable
    [1016/233611.932:ERROR:process_info.cc(632)] range at 0x0, size 0x296 fully unreadable
    [1118/050115.122:ERROR:process_info.cc(632)] range at 0x781299200000000, size 0x240 fully unreadable
    [1118/050115.152:ERROR:process_info.cc(632)] range at 0x78129b200000000, size 0x240 fully unreadable
    [1118/050115.152:ERROR:process_info.cc(632)] range at 0x0, size 0x240 fully unreadable
    [1126/182457.935:ERROR:process_info.cc(632)] range at 0x9552246400000000, size 0x151 fully unreadable
    [1126/182457.937:ERROR:process_info.cc(632)] range at 0x9552248400000000, size 0x151 fully unreadable
    [1126/182457.937:ERROR:process_info.cc(632)] range at 0x0, size 0x151 fully unreadable
    [1202/113602.885:ERROR:process_info.cc(632)] range at 0x7fc023b400000000, size 0x250 fully unreadable
    [1202/113602.910:ERROR:process_info.cc(632)] range at 0x7fc023d400000000, size 0x250 fully unreadable
    [1202/113602.910:ERROR:process_info.cc(632)] range at 0x0, size 0x250 fully unreadable
    [1219/005750.076:ERROR:registration_protocol_win.cc(56)] CreateFile: The system cannot find the file specified. (0x2)
    [1219/061220.157:ERROR:registration_protocol_win.cc(56)] CreateFile: The system cannot find the file specified. (0x2)
    [1219/061700.646:ERROR:registration_protocol_win.cc(56)] CreateFile: The system cannot find the file specified. (0x2)
    [1219/061835.873:ERROR:registration_protocol_win.cc(56)] CreateFile: The system cannot find the file specified. (0x2)

    If any of that makes sense to anyone, I sure could use an assist. I've tried opening Vivaldi in "safe mode," so to speak, disabling extensions, etc. Nada. Same thing.

    I'd like to figure this out instead of just starting fresh, because friggin Eversync has, apparently, not been auto-syncing for months, and I need to be in Vivaldi (this one) to export/upload all my data before I can afford to scrap the installation and start over. Yippee. Technology. Whoohoo.

    :)

    Any learned wisdom is eagerly appreciated.



  • Hi, check taskmanager if any Vivaldi process still run.
    If yes kill it, a system reboot should also help.
    You can test a new profile too: https://forum.vivaldi.net/topic/10388/refreshing-or-cleaning-your-profile

    Cheers, mib



  • Yes, 15 processes are running after I fire up the now faceless app. They all disappear when closing the program, as per normal. The GUI is simply vacant and unusable, as seen in the pic.

    Killing my default profile would be disastrous; the exact opposite of what I'm trying to achieve. That would axe all the data that I'm needing to fix the problem to access.



  • I should clarify, I already attempted porting the entire Default folder into a new "standalone" Vivaldi installation, but it just ignored the data entirely. It's a couple of extensions that I'm needing to be functional, long enough to back up the key data.

    This does raise the question, though. Do you think I could do the profile refresh, then selectively copy into it extension folders, in hopes of omitting whichever one (the common assumption) is causing the trouble? Could that possibly work?

    I don't know for certain that an extension is the cause, though. Seems odd that an extension could make the entire interface all but vanish like that.


  • Moderator

    @cthulhusaves Refreshing your profile does not kill it. You don't lose any vital data (only appearance preferences and bad sessions) You should carefully read the instructions.



  • I did, and gave it a shot. It works as far as getting Vivaldi to run, but when I try and add any extension folders it just ignores them completely. I can reinstall an extension, but any locally saved data is also ignored.


  • Moderator

    @cthulhusaves The locally saved data is in your old profile, and the newly installed extensions can and will read it if it's put back into the proper directory (which, not using extensions, I've never had to figure out how to do).

    If keeping a bad session is not vital to you, you can also try going into the original profile and renaming every file labeled "tab/tabs" or "session/sessions" and see if that fixes it. If so, your extensions are undisturbed. Where the problem might arise is if that blank window you're looking at is generated by an extension.


  • Moderator

    @cthulhusaves But what you know for SURE here, is that there is corrupted or incompatible data in the original profile, and that is what's gumming things up. You can't correct that data. You have to remove it.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.