https is removed when using self signed certificates



  • If I alter the URL manually in a https:// connection where there is a self signed (=not trusted) certificate Vivaldi removes the https:// automatically...

    0_1514878238169_Capture.JPG

    I connect to https://192.168.1.8:9090/dp/index.html and Vivaldi warns me (correctly) that the certificate is not trusted but I chose to continue anyway as I know the server.

    Once logged in I want to change view and go and manually change the URL, for example remove the "/dp/index.html" part:

    0_1514878690006_Capture2.JPG

    Vivaldi is then also changing from https: // to http:// and I loose my connection as the server only allows https connections. I have to manually go and add back https:// again for it to work.

    Is there any setting that would not have Vivaldi change the URL from https to http?

    Thanks!


  • Moderator

    Vivaldi 1.13 does not change the URL itself.
    https is not removed, i tested it with my untrusted router certificate. Typing in 192.168.0.10 gives me the regular http page which shows Not Secure in address bar.


  • Moderator

    You should download/export the certificate as .crt file, start you Windows user's Certificate manager and add the it to Windows → Trusted Root Certificates.
    At restart of Vivaldi you server connection will be trusted.


    !!! Own risk !!!
    Or you override the certificate (red lock) warning in Vivaldi
    when error page opened type on keyboard badidea



  • Ah, yes, I updated Vivaldi yesterday and now it is working as expected!

    Thank you!


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.