Youtube videos dropping frames



  • Hi there I have a problem (bug?) with Vivaldi. On Windows 10 Pro I get very many dropped frames on Videos with 60 fps it does not matter if the video is 1080p, 1440p or 2160p.

    Here is an example video:

    https://www.youtube.com/watch?v=6dRmTYyc7QU

    After 33 seconds I have 411 / 2053 droped frames and it also lags/buffers on ocasion from a little stop to a full few seconds.

    Those figures are in windowed mode. If I go fullscreen I only get 163 droped frames an no lags/buffering.

    I don't have this problem with any other browser and my system is powerful enough with a AMD 1950X, EVGA 1070 SC and 32 GB of RAM. Internet should also not be a problem with 200 MBit/s down- and 12 MBit/s upload.

    I'm runing Vivaldi on my Mac Mini 2012 with 0 problems. Same extensions (Cookie AutoDelete, ScriptSafe, SmoothScroll, Stylus and uBlock Origin) and even the same config where I can export them. I also tried a fresh install of Vivaldi and deleting my user profile after a new install - no luck.

    A friend of mine, also using Vivaldi, has no problems with a Ryzen 1700X, same GPU and 15 GB RAM so I can't tell if this is a Threadripper problem or something with windows?


  • Moderator

    Yes, the drops are very high in windowed mode and less in fullscreen for me on my WIn 10x64 with NVidia GT 710.

    Try to play with settings (one/both):
    a. Disabling Settings → Appearance → Use Animation helps
    b. vivaldi://flags/#disable-accelerated-video-decode



  • That might have helped however I also just updated my GPU drivers to version 388.71.

    Same Video I'm now at 161 / 2063 frames and no lags/buffering. Also tried a 2160p60 video:

    https://www.youtube.com/watch?v=788v0u5i14o

    seems like it works now with no buffering/laging. But I still get dropped frames. I don't get those on Firefox.


  • Moderator

    Try to change VSync in graphics card settings?



  • Turned it on and off still droped frames :-/


  • Moderator

    Perhaps you can override GPU blacklisting.

    Open vivaldi://flags/#ignore-gpu-blacklist and Activate and restart Vivaldi


  • Moderator

    On my 1.13 Stable on Win 10x64 with a 1060 video I get 10/2400 i if disable animation.


  • Moderator

    @gixxa said in Youtube videos dropping frames:

    Also tried a 2160p60 video:
    https://www.youtube.com/watch?v=788v0u5i14o

    with a 4K video drop is 40/2800 on my slow GT 710 card.



  • That's the actual problem, there are still occasional drops even if unnoticeable, firefox and chrome never drop a single frame even for 1h videos.
    With animations on, and in my case also hw video rendering enabled in flags, it's a mess.


  • Moderator

    Yes, Chrome and Firefox do not drop much. They have all their own paid/sponsored video/audio decoder software and are not affected by problems with external codecs.

    On Vivaldi reduce frame dropping is in progress.



  • I can confirm this problem in Vivaldi, I noticed slight video stuttering (frame dropping) on youtube videos - the movements are not as smooth as they should be and as they appear in other browsers.

    I turned off "Use Animation" in settings and this improved the situation but not completely. My computer is not modern but with AMD FX-4300 I think videos at 720p should be played perfectly but they are not. CPU usage of Vivaldi while playing in 720p with Animation is about 30%, of which the busiest Vivaldi process consumes about 15% CPU. When I turn off Animation then the usage is even lower, so there's plenty of unused CPU power in my case.

    What I noticed is that frame dropping happens not only in 60fps videos but also in 30fps. And for me the dropped frame numbers shown in stats for nerds are not always accurate: there are videos where the stats don't report any dropped frames but still I can see the motion stuttering. When I try another browser the motion is smooth.

    @gwen-dragon said in Youtube videos dropping frames:

    Yes, Chrome and Firefox do not drop much. They have all their own paid/sponsored video/audio decoder software and are not affected by problems with external codecs.

    As far as I can see most youtube videos in Vivaldi use VP9, which is a free codec so to me it doesn't look like any paid/sponsored codecs are needed.



  • i tried the video in the OP but I don't see any stuttering. youtube stats does show 21 dropped frames though.
    i have a intel 4770 and nvidia 1060.



  • Same problem here since i installed Vivaldi and already reported to "bug report"! even with latest updates the frame drop with youtube videos still happening!


  • Moderator

    Yes, we have on some hardware dropping. Many Bugs already reported in bugtracker.
    Fixes are in progress.



  • As others suggested here, disabling animations and then setting up a profile for Vivaldi in nVidia control panel setting Vsync to "Fast" fixed the problem for me. I have hardware acceleration enabled. I also use h264ify, not sure if that helps.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.