Vivaldi crashes with reddit link (videos)

  • Hi, this has happened before but now I can report this happens with my version 1.9.818.44 (Stable channel) (32-bit) and the newer version 1.13.1008.36 (Stable channel) (32-bit), the browser crashes when open the reddit link
    The browser just stops responding and I have to close the process, loosing all my other opened tabs

    This happens when opening embedded videos like that one, is it a bug ?


  • Moderator

    The 1.13 Stable has some crashes and issues on reddit videos, depends on graphics card and OS version.
    Unfortunately internal Chromium code for video may result in blacklisted graphics GPUs and codec problems. Then the Vivaldi devs work to workaround these issues.

    The freeze happens on all 1.13 and 1.14 Vivaldi :(

    I waiting for fixes, too โ€“ they are if progress.

  • In case some extra data would be helpful, I've experienced these crashes. My set up is:

    Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.97 Safari/537.36 Vivaldi/1.95.1047.3

    Intel i7-5500U, with Integrated Graphics; Alongside NVIDIA GTX 850M

  • Moderator

    Freeze happens on my NVidia GT710, too.

    May be a issue with Vivaldi using the Windows video codec for the video.

  • Thanks, I see I'm not the only one, here is my 1.9

    Vivaldi: 1.9.818.44 (Stable channel) (32-bit)
    Revision: bbec133a3745a0d97b9bd4da75e07ddb18f71ff7
    OS: Windows
    JavaScript: V8
    Flash: C:\Windows\SysWOW64\Macromed\Flash\pepflashplayer32_28_0_0_126.dll
    User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.82 Safari/537.36 Vivaldi/1.9.818.44
    Command Line: "E:\Vivaldi 1.9\Application\vivaldi.exe" --vivaldi-standalone --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --ppapi-flash-path="C:\Windows\SysWOW64\Macromed\Flash\pepflashplayer32_28_0_0_126.dll" --flag-switches-begin --flag-switches-end
    Executable Path E:\Vivaldi 1.9\Application\vivaldi.exe
    Profile Path E:\Vivaldi 1.9\User Data\Default
    Compiler MSVC 2015

    I have this info as video related information

    Operating System: Windows 8.1 Pro, 64-bit
    DirectX version: 11.0
    GPU processor: GeForce GTX 980M
    Driver version: 359.06
    Direct3D API version: 11.2
    Direct3D feature level: 11_1
    CUDA Cores: 1536
    Core clock: 1038 MHz
    Memory data rate: 5010 MHz
    Memory interface: 256-bit
    Memory bandwidth: 160.32 GB/s
    Total available graphics memory: 24552 MB
    Dedicated video memory: 8192 MB GDDR5
    System video memory: 0 MB
    Shared system memory: 16360 MB
    Video BIOS version:
    IRQ: Not used
    Bus: PCI Express x16 Gen3


    NvGFTrayPluginr.dll NVIDIA GeForce Experience
    NvGFTrayPlugin.dll NVIDIA GeForce Experience
    nvui.dll NVIDIA User Experience Driver Component
    nvxdsync.exe NVIDIA User Experience Driver Component
    nvxdplcy.dll NVIDIA User Experience Driver Component
    nvxdbat.dll NVIDIA User Experience Driver Component
    nvxdapix.dll NVIDIA User Experience Driver Component
    NVCPL.DLL NVIDIA User Experience Driver Component
    nvCplUIR.dll 8.1.850.0 NVIDIA Control Panel
    nvCplUI.exe 8.1.850.0 NVIDIA Control Panel
    nvWSSR.dll NVIDIA Workstation Server
    nvWSS.dll NVIDIA Workstation Server
    nvViTvSR.dll NVIDIA Video Server
    nvViTvS.dll NVIDIA Video Server
    nvDispSR.dll NVIDIA Display Server
    NVMCTRAY.DLL NVIDIA Media Center Library
    nvDispS.dll NVIDIA Display Server
    PhysX 09.15.0428 NVIDIA PhysX
    NVCUDA.DLL NVIDIA CUDA 7.5.0 driver
    nvGameSR.dll NVIDIA 3D Settings Server
    nvGameS.dll NVIDIA 3D Settings Server

    Hopefully vivaldi devs one day will make a crash reporter, when the browser freezes all the tabs are lost, I have to restore them with an extension called session buddy, or with the history feature

    Cheers anyway, the devs are awesome, happy holidays !!

  • I see that video perfectly, and I also have a Nvida GT 710, windows 7 32bit. Latest 1.14 snapshot. I tried with and without video HW decode setting

  • Vivaldi Voice

    Same issue here on Windows 10. The browser only freezes for me if I move my mouse cursor on the video (so it shows the pause/play button, voulme...) when Hardware-accelerated video decode is disabled, if it is enabled then it freezes when I try to skip in the video.

    I don't have any issues on OS X.

    I hope this issue gets fixed soon, pretty annoying to force close vivaldi multiple times a day because you opened a reddit video.

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.