Again Playback issues with video clips

  • I have to address the issues of video stuttering again cause it is damn annoying.

    1. I totally do not understand why you still haven't fixed the bug with video playback on (and I assume other pages) when turning on the "use animation" option (which is on by default) It's been known for ages now.
    2. Even when turning off the "use animation" feature some clips are still stuttering, for example: basically all clips of are unwatchable. The video start then load then plays a bit and loads again and so on. Guess some sort of buffering issue or whatever. It doesn't happen with FF or Chrome
    3. The last one is kind of more complicated and you probably won't be able to fix it as it appears in Chrome as well.
      I use a 2 Monitor set up where the primary monitor uses 144Hz and the secondary only 60Hz. For some reason streams with 720p60fps have a weird stuttering when I watch them on the second monitor. When I turn quality down to 720p30fps things get better a lot. This only happens on the second monitor with Vivaldi/Chrome. It works with FF tho.

  • I'm with you on that. Have exactly the same. Already added it as a bug as Gwen-Dragon told me so.

    I fiddled a lot with this, yesterday. Wondering if you also feel even worse stuttering when you got Vivaldi with a stream/clip on your second monitor and not having Vivaldi in focus?

    Then I found out, It could also be an issue with the latest NVIDIA drivers. I downgraded to version 388.00 and stuttering is a bit better, still not gone, but better then with the newest version.

  • @freeman79 I guess you are referring to point 3. For me it really doesn't make a difference if I have focus on my sencond monitor or not, when it's stuttering it won't stop until I move it to my primary monitor.

  • @pwalker said in Again Playback issues with video clips:

    @freeman79 I guess you are referring to point 3. For me it really doesn't make a difference if I have focus on my sencond monitor or not, when it's stuttering it won't stop until I move it to my primary monitor.

    This is an issues caused of your monitors have different refresh rates. At least that's what a lot of people statet on the internet.

  • similar issues here

    @pwalker said in Again Playback issues with video clips:

    I have to address the issues of video stuttering again cause it is damn annoying.

    Isn't it only for 1080p videos on Win 7?

  • I experience the same problem with stuttering and slow motion sound on W10 latest update. Vivaldi 1.14.1042.3 .

  • @pwalker Allow me to offer my input on this.

    I know of the stuttering that you speak of. It happens a lot when I play youtube at fullscreen. At first I blamed it on a bug with Vivaldi. How cannot I not, right? My system has 16GB of ram, and a GTX 1080ti w/ 12GB running the latest drivers (388.59).

    Well, let me say it's not Vivaldi's fault...or if it is, then it's also in Chrome, Opera, and any browsers that uses the chromium engine. It took me a half a day to figure out the problem and the fix. I even played around with vivaldi://flags, and even disable/enable the Override software rendering list.

    The problem is VSYNC.

    It took me so long to figure this out because I refused to touch vsync; I'm a gamer, and I hate having vsync on. And I thought, I have found the sweet spot by not enabling. Now the solution for me may be different for you, especially since you have 2 LCDs operating at different refresh rates. Mine is 60hz. You're going to have to experiment as I did. But in either cases, you will need to open up the Nvidia Control panel. And select Use the Advance 3D image settings:


    Now this is where you're going to have experiment. My settings may not work for you. On one PC with GTX 750 ti, I had to set the Vertical Sync to Fast; where's the same settings for the 1080ti
    gave me a shakey cam effect when playing youtube—much like one of JJ Abram's movies.


    For the 1080ti I had to set it to Use the 3D Application settings. I hope this helps.

  • Moderator

    @0blivion Thanks for this useful hint about VSYNC and settings of graphics card.

    <Offtopic> I never saw this on my Windows, thats why i often forget to tell users to check VSync. But I got this problem on Linux and wrote about.

  • It's not only video stuttering on twitch.
    It is also video freezing/stopping after re-focusing tab, dropping frames every several seconds nad slow motion sound.
    "Use the 3D Application settings" for vsync always enabled, on Firefox always works well, on Vivaldi issues on different PC's and snapshots.
    Freezing is also visible on Youtube 1080p videos but less than twitch.

  • @gregor Ok, "Use the 3D Appllication settings" is probably best for the Global vsync settings. But its not going to be all for every games and apps, that is why Nvidia in their infinite wisdom provided a per program basis, so you might have to add Vivaldi and play around with the 4 vsync settings.


  • @rhk Win10 Pro, latest Vivaldi here too. Also 1070 graphics

  • Moderator

    @pwalker Did you disable in Vivaldi Settings → Appearance → Animation? Did you try to change the Vsync setting in NVidia driver?

  • Changing Vivaldi vsync setting (any setting) and disabling Vivaldi animation doesn't help in any way for me.

  • @gwen-dragon I actually just tried out the vsync option, chose vivaldi.exe and "application controlled". It actually seems to work now without stuttering so far :-)
    The "Animation" option is disabled, I actually mentioned 3 probably completely different problems here in this thread. I just don't understand why they wouldn't disable the Animation option by default as it causes so many problems and you'd almost get no benefit from it.

  • I'm not sure and don't know why, but sometimes this function enabled vivaldi://flags/#enable-site-per-process helps for me for freezing streams and dropping frames. On the other hand if more than 3 streams opened cause videos shaking.

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.