Strange days indeed -- most peculiar, mama.



  • A most peculiar, indeed shocking, aberration just beset my V-SS, FireJail, Manjaro KDE combo on my Tower. It's never occurred before & i hope to dog it never repeats.

    After browsing for less than 90', maybe even only 60', & at that point still only on my "usual" daily sites, with everything [V & Manjaro] all being thoroughly tickety-boo [ie, sweet, nice, splendid, grouse, bonza, swell, sehr gut et al], i suddenly noticed that the cpu temperature was ~20 deg higher than usual [& definitely not explained by either ambient temperature or current user-induced pc load]. I then noticed that the avg cpu load was also unnaturally high, at ~30%. Inspecting Conky on my desktop revealed that 7 cores of the i7 were pretty normal but the 8th was at 100%. Furthermore periodically the cpu passed this 100% load to another core... at any one time only one core was full hammer & tongs, but it was not constantly the same core.

    Conky also showed me that it was Vivaldi that was associated with this naughty misbehaviour. Gulp. V itself superficially appeared to be as good as ever, so i dug deeper via the V Task Manager. When i sorted on the cpu column, the top entry was "Browser" at 105 [what are the units; percentage?], yet NO individual tab was using anything at all notable cpu-wise [thus eliminating my suspicion that one of my tabs had a hidden crypto-miner]. This was all weird enough, but it was about to get weirder.

    Given no individual tab seemed guilty, yet Vivaldi itself was somehow eating a core, the logical thing seemed to be to close V. I did so, & it vanished from desktop & the Plasma Task Manager, but Conky showed no benefit from that wrt cpu core-load & temperature. It also showed that some V processes were still running. "Continue running background apps when Vivaldi is closed" is always set to OFF, & i have just reconfirmed it now, so this naughtiness simply ought not have occurred.

    I run all my browsers, & many other pgms, in Firejail [latest stable version]. When i looked in its FireTools GUI i saw that indeed V was still running in the FJ sandbox. Multiple attempts to kill it there, failed. Hmmm, what the foooook is going on?

    Turning my attention to KSysGuard, i tried to kill each V & associated FJ process there... again everything i did was ignored. Bugger. OK, i closed all my other pgms, & then logged out of my Manjaro session, then logged back in. Oh you have got to be kidding me... those bloody V processes were still running, & so the cpu load on one core was still 100%. Gahhh. I've never seen such misbehaviour before.

    Nuclear option... reboot. One final unpleasant surprise; whilst plasmashell correctly closed as soon as i clicked the Reboot icon, which normally takes me briefly to TTY, this time i got stuck in TTY whilst various protracted Stop Jobs ran. Eventually all that silliness finished, & the reboot occurred.

    Everything now once again appears to be tickety-boo... cpu 39 - 42 [hey, the Ultimate Answer] deg C, 6% avg, all 8 cores < 10%, V Task Manager showing utterly benign data everywhere.

    Never have i seen this before... never do i want to see it again. I dunno whether it was the fault of V, of FJ, of Plasma5, of Manjaro, of sunspots, or of rabid evil arch-conservative politics in general. Strange days indeed -- most peculiar, mama.

    PS: I do hope, btw, that there's sufficient fans of The Great One to understand my subject line...

    PPS: i had briefly pondered if this morning's naughtiness was related to this https://forum.vivaldi.net/post/179745 , but no... that was apparently a memory issue, whereas my incident was completely cpu related.



  • John Lennon is "the great one"? Peculiar. :p



  • @sgunhouse Redundant question mark.



  • @steffie My first thought is Sync; server problems are sometimes/often happening atm?



  • @tbgbe Except...

    0_1513167567672_20171213_003.png

    I... don't use it, don't care about it, don't activate it.

    My money's firming on rabid evil arch-conservative politics in general as root cause. ;-)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.