How to get the most out of search engines in Vivaldi


  • Moderator

    @para-noid: I think only with Mozilla nowadays. They used to have partnerships with many browsers before, but they created their own and achieved monopoly so they don't need to pay others anymore.



  • @an_dz I see. Thank you. I wish I had known that when using DDG hoping that my searches were private.

    I did read online that GET is faster than POST. However, I don't really see a difference in speed when using DDG on POST and on GET when searching for something, like for example "dogs".



  • @aronand It is not about bundling the Ecosia search, that was done, but about the search predictions for Ecosia - which is not in by default. Just tested again with clean profile - see last comment in VB-27327 - maybe the string should be added at some point too 😉


  • Moderator

    @d0j0p
    One of the "disadvantages" of searches with GET is that you won't be able to go back to those searches when looking in your history. You'll have to retype what is shown there. But that's a choice each person can make for themselves.

    Tip

    Also, if you want to always force POST in DDG, including in private windows, you can add &kg=p at the end of the search string. This will force POST. Obviously the Use POST checkmark must be checked as well.



  • @an_dz When I edit my DDG search in Vivaldi settings, it shows "https://duckduckgo.com/?q=%s&t=vivaldi" as the search engine address. Where in there do I put &kg=p? I tried it after the .com/, and I tried it at the very end, and then going to that URL, but it did a custom search for me.


  • Moderator

    @d0j0p
    It should be at the very end, https://duckduckgo.com/?q=%s&t=vivaldi&kg=p

    When you search kg=p will tell DuckDuckGo the setting for using POST must be set.



  • Suggestions to the Search Field:

    1. Replace the icon of the magnifying glass with the icon of the currently selected search engine. Also show system icons in the context menu "Search with".
    2. Reset search engine after performed search to the search engine by default. With the setting of the delay before the reset, if not click again in the search field.


  • I'm trying to add a Google 1-year search to the list of search engines. I'm using https://www.google.com/webhp?tbs=qdr:y but, when I put the search information in the search bar, it brings up Google with the 1-year search but does not carry the search criteria with it. I have to input it again.

    Any suggestions? Thanks.


  • Moderator

    @tonycr You did not add where the query must be placed so it only opens the Google frontpage. Add &q=%s at the end of the url and it will work.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.