can't use Vivaldi when changed language



  • I changed the language of Windows10 from Japanese to English. Then I returned to Japanese. Then Vivaldi became a gray only window like the attached image. I can not operate anything any longer. I press the Alt key and the Vivaldi menu is displayed. When I create new windows and tabs, the same gray window is created.
    0_1512434672858_vivawin.png

    I also experienced this on the Mac version. In other words, this is a bug or specification of Vivaldi. The Mac version solved by replacing Profile. But Windows version did not backup Profie. Is there a way I can revive Vivaldi?



  • Try going to %AppData% with the Windows Explorer and back up Vivaldi folder - Profile -.

    Then, open Preferences file with notepad and look for {"accept_languages":, mine looks like {"accept_languages":"en-US,en"}.

    Don't know if changing OS language may messed it being that as you told, the Menu appears.

    Then you can follow the clean profile steps while a fix response arrives.


    Windows 10 (x64) | Anniversary Update
    Vivaldi Stable · Snapshot

    Vivaldi Reset and Back up



  • @zalex108 said in can't use Vivaldi when changed language:

    Don't know if changing OS language may messed that if Menu appears...
    Then you can follow the clean profile steps while a fix response arrives.

    The position of the Vivaldi menu is lower left. There is no problem in displaying menu items. Of course, selecting a menu does not work. I can rarely close the window from that menu. Basically it is Alt+F4 to end Vivaldi.

    /User/Appdata/Local
    There is only Vivaildi folder here(/Vivaldi/User Data/Default/). There is a file named Preferences in it, but its content has no "accept-languages". Where is the Preferences file?



  • Maybe it's the problem and you need too create it, this is the full content on mine install between other code:

    ,"intl":{"accept_languages":"en-US,en"},

    --
    ,"http_received_content_length":"10722264198","intl":{"accept_languages":"en-US,en"},"invalidator":{"client_id":"TUeSZWSuDhniBQyZbfMBLQ=="},

    Maybe adding it in any part is enough, but respect the , commas.

    If not, try to find some part of the other code I've pasted.



  • I've forgot it, this would be better.



  • @zalex108 The "Preferences" file seems to be generated by something. Even if I add accept-languages to it, it will be overwritten.



  • @izacks

    Then, keep the back up safe until someone help you better than me, and meanwhile use a clean profile.

    --

    As a last idea, modify it and mark the file as "Read only".



  • @zalex108 Sorry. I inserted that code and made the file itself read-only, but Vivaldi had no effect.

    I usually do not see the process at the task manager of Vivaldi, but this time around 10 processes are present as I see the process. Even if I end with Alt+F4, the process will stay, so I need to manually terminate the process.

    I found a pretty old Vivaldi Profile folder. Is there any file that can be replaced?



  • @izacks You could try to refresh your profile and if this solves your issue you could copy the preferences file from the fresh profile to your old profile and and use the old one with all your settings again.

    To refresh your profile do the following:

    1.) go to vivaldi://about in the second line from the bottom there is listed a path (it should end on "/Default")

    2.) Copy that path or memorise it --> close vivaldi and go there in your file explorer

    3.) Now copy the "Default" folder to a backup location and delete it in your vivaldi directory.
    Your Default folder contains all your settings bookmarks and other data - so please make a backup as said above you'll need this later on!

    4.) Restart vivaldi - on a start of vivaldi without a Default folder vivaldi will create a new one

    5.) Have a look if your issue is solved --> if the answer is yes than proceed and copy the preferences file from your new profile to the backed up default folder and override the corrupted one after you made a backup of the old preferences file (just in case).

    6.) Now close vivaldi again and delete the new Default folder and copy back the old one with the fresh preferences file

    Please note - as the preferences file contains data about your screen(s) height and width it may be that you'll need to adjust the window(s) and some settings again because such changes aren't already written in the new preferences file of course.

    Hope this helps



  • @zaibon Sorry again. There is no change in Vivaldi.
    Does the "Prefereces" file that I recognize are different from the files you are telling me? There is only one such "Preferences" file name with no extension. Does it exist elsewhere?



  • @izacks
    Sorry to hear that this didn't changed anything for you.
    And no there should be only one preferences file (with no extension) in the default folder.



  • Thank you for everyone.
    I gave up restoring. Only Bookmark succeeded. I had a hard time resetting the add-on. From now on I will try to back up at an earlier timing.

    If you use Vivaldi, I recommend that you don't switch the operating language of the OS.



  • I suppose it will be investigated since it has no sense.

    Now, periodical back ups and restore points.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.