Strange Permissions Dilemma



  • Yesterday I set up my replacement iMac as Admin user. The other one has El Capitan. This new one has Sierra. I imported my files, folder and applications. Sierra dumped Firefox off the dock and the Vivaldi icon was replaced by an icon that was a text page with the Apple App triangle logo on it. In Applications the Vivaldi name was noted as having zero bytes. I switched to non-admin user and the situation was the same, came here in Safari and downloaded Vivaldi 1.14.1030.3 and set it up using Admin and password. Vivaldi worked fine and had all of the original bookmarks. I switched to Admin account and clicked to open Vivaldi which had the black and white logo in Dock. A popup said that I do not have permission to open Vivaldi so i tried to change permissions in Get info but it did not work. Then I switched back to non-admin user and tried to change permissions there but got the same negative response. Do I download another Vivaldi while in Admin user?


  • Moderator

    @echosyn This is a known issue - the file permissions were set incorrectly when this version of Vivaldi was built. The following was added to the posting in the Snapshot Blog:

    [Mac] [Regression] Only the user who has installed Vivaldi in Applications has the permission to launch it (VB-35083)

    The file permissions in the application bundle can be fixed manually but I suspect that a new build will be out imminently to correct this and other issues.



  • @xyzzy Thank you. I came back, logged in and read the Regression then I installed the same version in my wife's iMac heeding the caution. Vivaldi 1.14.1030.3 is working well in both computers. She uses iMac 8,1 with El Capitan and I now use iMac 12,1 with Sierra. Note that I do not do SYNC so I cannot report on that.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.