Web panels - no longer showing a "responsive" view?



  • Hello, I have been using Vivaldi for a while and really love the web panels feature. Mostly I use it to display my Twitter feed.

    I have Vivaldi installed on a couple of machines, one which is using a slightly older than current version (1.10.867.38) and one that is up to date (1.13.1008.32).

    I noticed when I updated though (albeit after having to trash my Windows User Data folder, due to Vivaldi not starting up) that my Twitter feed (once re-added to the web panel) is no longer showing in a responsive view, and instead I need to scroll to the right (or increase the width of the panel) to see the content.

    Although I just had to also trash the User Data folder on the "older" version, when I re-added Twitter as a web panel the same issue doesn't occur (ie. in v1.10.867.38 I still see the responsive view, and don't have to scroll right or increase the panel width).

    Is this a known issue in v1.13 or is there something I can do about it?

    Two screenshots attached, one with the older version and you can see the Twitter login page is showing in "mobile" view, and has adapted to the width of the panel.

    The second is from the latest version, where you can see the Twitter login page has not adapted to the width of the panel.

    Thanks!

    0_1512078347129_vivaldi-older-version.PNG

    0_1512078419990_vivaldi-newer-version.PNG



  • @drteethwastaken
    Does this behaviour change when you rightclick the webpanel icon and choose "Show mobile version" or switch it back and forth between mobile and desktop version?
    Although I've just added twitter for testing to a webpanel and in both the mobile and the desktop versions the twitter page adjusts itself to the correct width.



  • Twitter changed the website and detects that Vivaldi sends a mobile client user agent and redirects to mobile.twitter.com.
    You have to resize the panel and make it wider to see the login page correctly.



  • @gwen-dragon
    Thanks Gwen, changing it to the mobile URL seems to have done the trick.

    @zaibon to answer your question though, no it was as though the web panel already thought it was in mobile view. Right-click on the web panel showed me the option to "show Desktop version" (which effectively it already was).

    Changing the URL to https://mobile.twitter.com seems to be the answer.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.