No more Vivaldi build for Macos 32 bits snow leopard 10.6.8

  • i'm running the first vivaldi release , the newer versions are not compatible with my device , when i try to install i see always the non compatible icon ... so i can't see and get the new features... is this something preview like for linux , for a 32 bits version for my 10.6.8 computer ? Thanks in advance

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.